CUDA 8.0 installation error due to dependency packages

Hi,

We have configure 3+1 rocks 6.2 HPC cluster.
Single compute node is installed with Nvidia Tesla K80 GPU,when we try to install the CUDA using Yum install CUDA,we are getting multiple dependencies packages and not able to get the correct packages for the same.

we tried to install dkms but it has more package dependencies

error details are as below,
----error: Package: 1:nvidia-kmod-367.48-2.el6.x86_64 (cuda)
Requires: dkms
Error: Package: cuda-samples-8-0-8.0.44-1.x86_64 (cuda)
Requires: freeglut-devel
Error: Package: 1:xorg-x11-drv-nvidia-libs-367.48-1.el6.x86_64 (cuda)
Requires: libvdpau(x86-64) >= 0.5
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles –nodigest

[root@compute-0-2 ~]# yumdownloader libvdpau.i686
No Match for argument libvdpau.i686
Nothing to download

Details of compute node as below,
root@compute-0-2 ~]# uname -r
2.6.32-504.16.2.el6.x86_64

root@compute-0-2 ~]# lspci | grep N
02:00.0 Network controller: Mellanox Technologies MT27500 Family [ConnectX-3]
08:00.0 3D controller: NVIDIA Corporation GK110BGL [Tesla K80] (rev a1)
09:00.0 3D controller: NVIDIA Corporation GK110BGL [Tesla K80] (rev a1)
PLease help to resolve the issue.

you’ll need to install dkms

did you google how to install dkms on RHEL ?

have you read the cuda linux install guide? Things might be easier if you use the runfile installer method

Hi,

If we install via run file method dependency packages will not be installed and CUDA might not work same has been mentioned in installation guide.

Yes I have read install guide,tried commands like yumdownloader.

kindly suggest download link or best method to resolve all dependecies. dkms,freegult-level,libvdpau(x86-64) >= 0.5 and also resolve dependents for these packages