CUDA 8 downgrades the driver 384.59 to 375.26

After installing in a Centos 7 the nvidia driver 384.59, in order to install CUDA 8 I have downloaded the corresponding rpm packages. The installation process downgrades the nvidia driver to the 375 version installing in addition dependencies as nvidia-kmod. Why? Should I give up and remove the 384.59 driver for the sake of compatibility with CUDA 8?

Thanks in advance.

The downgrade can be avoided using the *.run installation file instead of the *.rpm. Is keeping the 384.59 driver this way a bad idea?

Thanks again.

No, keeping the 384.59 is not a bad idea.

Ok. Thanks.

For us owners of the 1080 TI series and newer pascal GPUs: The driver version included with CUDA 8.0, 375.26 does not recognize these newer Nvidia products, which requires us to use newer driver versions up to 384.59. In an Ubuntu/Linux installation, overwriting the drivers may cause issues. There is a workaround by using the local runfile installation, which allows you to bypass the automatic install of 375 drivers. This is really kludgy.

Nvidia CUDA dev team - please update the 8.0 CUDA to current stable 384 version so Titan Xp and 1080Ti owners can have Use of CUDA without jumping through even more hoops? Thank you.

I’ve found this to be true of the GTX1060 as well. The version of NVIDIA drivers that you get is different from what cuda expects. As you can see, nvidia-modprobe is built for 375.26, while all the other packages use either 384.69 or 375.82.

dpkg -l | grep nvidia
ii  bumblebee-nvidia                                            3.2.1-10                                     amd64        NVIDIA Optimus support using the proprietary NVIDIA driver
ii  nvidia-375                                                  375.82-0ubuntu0~gpu16.04.1                   amd64        NVIDIA binary driver - version 375.82
ii  nvidia-375-dev                                              375.82-0ubuntu0~gpu16.04.1                   amd64        NVIDIA binary Xorg driver development files
ii  nvidia-modprobe                                             375.26-0ubuntu1                              amd64        Load the NVIDIA kernel driver and create device files
ii  nvidia-opencl-icd-375                                       375.82-0ubuntu0~gpu16.04.1                   amd64        NVIDIA OpenCL ICD
rc  nvidia-prime                                                0.8.2                                        amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                                             384.69-0ubuntu0~gpu16.04.1                   amd64        Tool for configuring the NVIDIA graphics driver

I get a similar problem on Kubuntu 16.04. The CUDA installation wants to downgrade my NVIDIA driver from 381 to 375.

Is there a way to avoid the driver downgrade on Kubuntu?

Many thanks!

I experience the same issue, on Ubuntu 16. After installing 384.69 stable driver version, the Cuda 8.0.61 installation automatically downgrades the driver to 375.66.

Is there any estimation about adding the new stable driver (384 version) to CUDA 8 ?

Note: I’ve since resolved my CUDA/Driver issues, so my earlier comment is mostly useful as a historical artifact, evidence of problems in my earlier setup.

If you install the CUDA runtime using the runfile (like this:, you should be fine using the latest NVIDIA drivers. That method of installing CUDA 8.0 doesn’t really care, as you can run:

sudo ./ --toolkit

But if you install CUDA using the .deb, you’ll get the drivers whether you like it or not.

I have same problem … i have 1080 ti and i want install cuda8 … whish driver must be install 375.26 or 375.82

Either of those drivers will work with CUDA 8. I would use the later one (375.82)