cuda 9.0 on CentOS7.5

Hi all,

I’m planning to try deep learning on CentOS using cuda.
So I got a GPU from NVIDIA and installed it on my CentOS but
as soon as I installed cuda9.0, X window does not start.
I mean after I installed cuda9.0 on my console(X is off) I tried to
start X window with the command “startx”, it crushed
with a segmentation fault shown below.
I tried to recreate /etc/X11/xorg.conf with the command
“nvidia-xconfig -o xorg.conf --busid=PCI:1:0:0” but everything I tried failed so far.
Could anyone tell me how to fix it and how to use cuda9.0 on X.

My environment and the error message are listed below.

environment
OS: CentOS Linux release 7.5.1804 (Core)
CPU: Intel i5 2.8GHz (8th gen)
GPU: NVIDIA Geforce 1070
driver of GPU: NOT nouveau but the one from NDIVIA

error message(/var/log/Xorg.0.log)
[ 41.821] (II) Loading sub module “fb”
[ 41.821] (II) LoadModule: “fb”
[ 41.845] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 41.858] (II) Module fb: vendor=“X.Org Foundation”
[ 41.858] compiled for 1.19.5, module version = 1.0.0
[ 41.858] ABI class: X.Org ANSI C Emulation, version 0.4
[ 41.858] (II) Loading sub module “wfb”
[ 41.858] (II) LoadModule: “wfb”
[ 41.859] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 41.864] (II) Module wfb: vendor=“X.Org Foundation”
[ 41.864] compiled for 1.19.5, module version = 1.0.0
[ 41.864] ABI class: X.Org ANSI C Emulation, version 0.4
[ 41.864] (II) Loading sub module “ramdac”
[ 41.864] (II) LoadModule: “ramdac”
[ 41.864] (II) Module “ramdac” already built-in
[ 41.880] () NVIDIA(0): Depth 24, (–) framebuffer bpp 32
[ 41.880] (==) NVIDIA(0): RGB weight 888
[ 41.880] (==) NVIDIA(0): Default visual is TrueColor
[ 41.880] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 41.881] (
) NVIDIA(0): Enabling 2D acceleration
[ 41.899] (EE)
[ 41.899] (EE) Backtrace:
[ 41.899] (EE) 0: /usr/bin/X (xorg_backtrace+0x55) [0x56458cd0a135]
[ 41.899] (EE) 1: /usr/bin/X (0x56458cb5c000+0x1b1ec9) [0x56458cd0dec9]
[ 41.899] (EE) 2: /lib64/libpthread.so.0 (0x7f1d21e19000+0xf6d0) [0x7f1d21e286d0]
[ 41.899] (EE)
[ 41.899] (EE) Segmentation fault at address 0x0
[ 41.899] (EE)
Fatal server error:
[ 41.899] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 41.899] (EE)
[ 41.899] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 41.899] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 41.899] (EE)
[ 41.900] (EE) Server terminated with error (1). Closing log file.
nvidia-bug-report.log.gz (896 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

The driver is incorrectly installed, the kernel driver is version 410, the X/GLX driver is version 390. You should clean/uninstall driver and cuda and then use the cuda rpm.
What did you use to install cuda and driver?

Thank you for your decent advice.
I understood the reason for the segfault.

I got cuda from https://developer.nvidia.com/cuda-90-download-archive?target_os=Linux&target_arch=x86_64&target_distro=CentOS&target_version=7&target_type=rpmnetwork.

I got the 390driver from https://www.nvidia.co.jp/Download/index.aspx?lang=jp.
So far 390 is latest for Geforce 10series, linux-64bit, CentOS7.

But when I change the condition to Geforce 20series, I can get the 410driver
even though my GPU is Geforce 1070.
Should I get the 410driver in the way shown above?
Or is there a way to get 410driver for Geforce1070?

Ok, that clarifies it. The cuda package also includes the driver, so when you did the second step and installed the driver, you got a mixed install. So please uninstall both, then just install cuda. If you’re thinking about upgrading to the RTX20xx series, you might already want to install cuda 10 instead of 9.0.
Edit: this should also give you the 410 driver.

Thank you for your help, generix.
I made it!