CUDA 9.0 patch 1 crashing on loading screen

Hello everyone, I am trying to install the first patch for CUDA 9.0. However, after designating the path to install (the default path) the installer is loaded. When the green loading screen appears, it crashes after less than a second. This seems bizarre considering that the second path seems to install fine.

In case it is of use here are my system specifications:

processor: Intel Core i3
Graphics card: GTX 1050
RAM: 10 GB DDR4

any help would be much appreciated. thanks,

Alex Shepherd

You might need to uninstall and clean reinstall. See some possible steps here:

https://devtalk.nvidia.com/default/topic/1037027/cuda-setup-and-installation/cuda-installation-failed-on-1050ti/post/5268413/#5268413

I am having the exact same problem as original poster. I installed Cuda 9.0 first on a machine with no cuda install on it. It installed successfully without Visual studio integration, geforce experience or drivers and Physx. I have newer versions already installed.

I then restarted my computer and attempted to install Patch 1 with and without admin rights and on every occasion the nvidia install GUI appears for less than a second after the temp files are extracted and then disappears. I have tried a different folder for extraction as well.

Patches 2 and 3 for Cuda 9.0 install just fine, it’s only patch 1 that fails. Does patch 2 or 3 include patch #1?

Update: I have checked my System Environment Variables Paths to make sure 9.0 was there correctly, it somehow had an instance I found of something that wasn’t 9.0 so I deleted it. I still cant install patch 1 though :(

Intel I7-6770K, 980Ti GPU. Latest Drivers and windows 10 updates. Visual Studio 2015 Update 3.

For any one seeing this in the future, I found a fix. This fix applies to CUDA 8.0, 9.0, and 9.1 where you cant install Patch 1. First, download the Display Driver Uninstaller (DDU) from here: http://www.guru3d.com/files-details/display-driver-uninstaller-download.html

Once downloaded, extract to the desktop, and open the executable. It will prompt you to reboot to Safe mode, ignore this message.

Next, click “Clean and do not restart”. Note: This can cause black screen issues, but most of the time Windows default display driver kicks and works temporarily.

Once it has finished, check the Control panel to make sure everything has been removed. DO NOT REBOOT! (unless uninstalling drivers and left you in black screen)

Next, download your CUDA version and the following patches. Now this time, use the express installation, and install drivers and GeForce experience with the CUDA installer. (If the Visual Studio integration causes your installation to fail, choose Coustom and only deselect that option).

Once CUDA and your display drivers have finished installing, proceed to Patch 1. And now it should work with no issues! This is what I did and it worked for me!

There is a better and easier method to try than uninstalling and reinstalling your drivers.

https://devtalk.nvidia.com/default/topic/1039261/cuda-setup-and-installation/cuda-9-0-patch-1-installation-problem/post/5284241/#5284241

Following that link, the user “Fancy” posted:
“Can you try Deleting C:\Program Files\NVIDIA Corporation\Installer2 and then try to install once again.”

just deleting that folder solved the problem for me

2 Likes

@Tawfiq_altai, thank you for your solution. It works perfectly!

1 Like

Thanks so much!

1 Like