CUDA 9.1 does not work with the latest VS 2017

with the message “Error C1189 #error: – unsupported Microsoft Visual Studio version! Only the versions 2012, 2013, 2015 and 2017 are supported!”

(and “if _MSC_VER < 1600 || _MSC_VER > 1911” has already been 1911)

I have the same issue.

https://devtalk.nvidia.com/default/topic/1028669/how-to-get-visual-studio-2017-to-use-cuda-9-1-/?offset=12#5245977

Reinstall Windows10, than install previous Vs2017 15.4.5 En(because of Vs2017 only c++ compile tools not c++ Vs2015!), install Cuda 9.1 + patch 1 to 3. Update Driver 391.01. Just like friend vote and comment by adding a post, if it also works now fine for you, too.

Same problem. Will it be solved some day ? I am not going to re-install Windows, i got a lot of other programs to run in the meantime.