CUDA 9.2.props file missing??? I followed the Windows Install guide but nothing compiles and a lot of files are missing.

Help I have tried installing dozens of times on 2 different PC’s from scratch every time. I’ve spent weeks trying desperately to get anything related to CUDA working. Nothing will let this compile. There is only one version of VC++ (15.7) so I don’t see why you say to only support 15.0 and 15.6. Microsoft does not sell or allow for the usage of such things? Where can I buy or get 15.0? All they have is 15.7 now? The installation guide is missing key pieces of info it just seems to assume we work for nVidia and understand maybe 75% of what is secretly going on. It’s so confusing.

How do I get CUDA to compile on Windows 7?

https://docs.microsoft.com/en-us/visualstudio/productinfo/installing-an-earlier-release-of-vs2017

Thank you! Which one do I download? I have the free community version of 2017.

the instructions indicate you have to remove your version first.

after you do that, I think the 15.6.7 community.exe should work with CUDA 9.2

For best probability of success, you may need to uninstall all NVIDIA software before starting this process:

https://devtalk.nvidia.com/default/topic/1033111/cuda-setup-and-installation/cuda-9-1-cannot-install-due-to-failed-visual-studio-integration/post/5259359/#5259359

I reinstalled everything and this time I tried 15.6, same problem. The CUDA installer fails to install the Visual Studio plugin, and now all the CUDA files are missing in the Visual Studio directory.