Cuda and nvidia driver setup failure on Centos7

I am trying to get a K20 setup on a HP DL380p g8 for some cuda and accelerated vms. I have a fresh install of centos7 and get an error about Unable to load the ‘nvidia-drm’ kernel module.

I have tried 396 410 and 418 non of them will load. I have also tried 3.10 4.4 and 5.2 kernels. any suggestions would be appriciated

Your bios only has 32bit resources enabled, please check it for an option like “above 4G decoding” or “large/64bit BARS” and enable it.

Thanks for the info. after circling around several times in various forums I finally found a hint. Ctrl + A in the HP dlxxx G8 bios gives you a hidden menu option that includes the bar memory option. I will be trying this out tonight when I can get to that specific machine.

Looks like nobody ever finds that option:
https://devtalk.nvidia.com/default/topic/1063089/linux/nvrm-this-pci-i-o-region-assigned-to-your-nvidia-device-is-invalid/post/5383514/#5383514

sadly HP does not make it easy to search for that information either. I finally sumbled across another post simler to that one for a ml320? since they dont document all the items and you dont know what is cross compatible its hard to find the info