Cuda and pytorch problem at running AlphaPose.

When I ran the AlphaPose, it comes out a cuda runtime error (71). The details:

Loading YOLO model…
THCudaCheck FAIL file=…/torch/csrc/generic/StorageSharing.cpp line=232 error=71 : operation not supported
Traceback (most recent call last):
File “”, line 50, in
det_loader = DetectionLoader(data_loader, batchSize=args.detbatch).start()
File “/home/wu/AlphaPose/”, line 309, in start
File “/usr/lib/python3.6/multiprocessing/”, line 105, in start
self._popen = self._Popen(self)
File “/usr/lib/python3.6/multiprocessing/”, line 223, in _Popen
return _default_context.get_context().Process._Popen(process_obj)
File “/usr/lib/python3.6/multiprocessing/”, line 291, in _Popen
return Popen(process_obj)
File “/usr/lib/python3.6/multiprocessing/”, line 35, in init
File “/usr/lib/python3.6/multiprocessing/”, line 19, in init
File “/usr/lib/python3.6/multiprocessing/”, line 47, in _launch
reduction.dump(process_obj, buf)
File “/usr/lib/python3.6/multiprocessing/”, line 60, in dump
ForkingPickler(file, protocol).dump(obj)
File “/home/wu/.local/lib/python3.6/site-packages/torch/multiprocessing/”, line 214, in reduce_tensor
(device, handle, storage_size_bytes, storage_offset_bytes) = storage.share_cuda()
RuntimeError: cuda runtime error (71) : operation not supported at …/torch/csrc/generic/StorageSharing.cpp:232

And I have add these to ~/.bashrc :

export PATH=/usr/local/cuda/bin:$PATH
export LD_LIBRARY_PATH=/usr/local/cuda/lib64:$LD_LIBRARY_PATH

Have anybody met this problem and know how to deal with it? Please give me help!!

I solved this problems by using:

python3 --indir examples/demo/ --outdir examples/res --sp

but, then it becomes:

Loading YOLO model…
Loading pose model from ./models/sppe/duc_se.pth


‘Killed’ is a common error when running out of memory.
Do you mind to monitor your system with tegrastats at the same time and share the log with us?

sudo ./tegrastats