CUDA app on windows server 2008

Will a CUDA application run on Windows Server 2008? Are there any driver issues?

It will run with the same caveats as Vista.


I work on windows server 2008 enterprise 64 bit, graphics card: NVIDIA GeForce 8600 GTS (driver version:, Visual Studio 2005.

I have installed: cudatoolkit_2.2_win_64 (for vista) and cudasdk_2.2_win_64

After it, invoking command “nvcc -V”


"nvcc: NVIDIA ® Cuda compiler driver

Copyright © 2005-2009 NVIDIA Corporation

Built on Sat_May__2_05:54:12_PDT_2009

Cuda compilation tools, release 2.2, V0.2.1221"

is generated.

But ‘bandwidthTest’ (as suggested in the CUDA_2_Quickstart_Guide manual, in proper folder invoked of course), fails with message:

"Running on…

  device 0:Device Emulation (CPU)

Quick Mode

Host to Device Bandwidth for Pageable memory

cudaSafeCall() Runtime API error in file <d:/

A_2.2/SDK10/Compute/projects/bandwidthTest/>, line 667 : no CUDA

-capable device is available."

I have tried several options, various drivers (for Win XP, Win Vista from cuda webpage and from NVIDIA webpage) and the error is the same.

Additionally I tried to invoke applications via “NVIDIA CUDA SDK Browser” - it fails and compiling projects (under 64 bit compiler) fails with message

“Error 1 fatal error LNK1181: cannot open input file ‘.\x64\emurelease\’ bandwidthTest”

I had the same error message for the precompiled sample applications.

To “solve” (or better: work around) it, it was enough to run the CUDA application once as Administrator.

Afterwards, you can run any CUDA app as normal user.

I suppose, this is due to some initialization/registration stuff that can only be done with Admin rights.
So you may have to repeat this after each reboot.

Good luck,

I’m have the same problem as the OP but this solution doesnt appear to change anything. I still get the same error, whether I run the installed binaries or recompile the samples. Anyone else have any hints? I’ve installed the 191.00 driver successfully and the device manager reports that both the Tesla C1060 board and the NVS 290 are using it. I’m logging in to this server remotely over TS, could that be preventing the driver from working?

In Vista/Win7/Server 2008, you can’t run CUDA programs in session 0 (which is what is happening when you use remote desktop). I haven’t heard of a solution to the problem at this time (it’s a Windows issue, not a CUDA issue), other than to use a VNC server/client instead (since it works differently than TS).

EDIT: I should point out that this also means that you can’t run CUDA apps as a service under these operating systems, either, without some very in-depth (and possibly insecure) hacks.