CUDA APP Problem with Multiple Monitors A clock speed error (speed switch failure) in mult-monitor m

Setup: 4 monitors on 2 GTX 460 cards in SLI. System specs are Windows 7-64b, DUAL Asus GTX 460’s in SLI. Nvidia Driver version 270.61.

Background: The GPU clocks change from 405MHz to top speed (default 675MHz on my ASUS GPU’s) as required when a graphics app like Heaven 2011 or a game is played. Multi-Monitor mode is NOT an SLI mode and only the primary graphics adaptor is used. It is NORMAL for the cards to idle down to 405MHz when not in heavy use and NORMAL for them to speed up when in heavy use. On first use, a BOINC CUDA app also causes the GPU’s clocks to ramp to full speed.

Problem: When running any CUDA task under BOINC Manager, either exiting altogether or just snoozing the GPU causes speed switching to fail! The cards idle down to 405MHz and NEVER EVER will switch back to high speed (675MHz in this case)!!!

REBOOT fixes speed switch problem until ANY single or multiple CUDA task is run, then repeat locked in slow speed mode.

Resetting to max performance mode, single monitor (SLI Enabled) cures the problem.

Running CUDA tasks in single monitor SLI mode works properly!!! The clocks switch properly even with snoozing GPU or exiting. I cannot find any task or app that prevents proper speed switching in SLI mode.

But, again, in muli-monitor non-SLI mode, the problem is very repeatable. It doesn’t matter if you use GPU-Z or MSI After Burner or whatever to monitor the clock speed. In fact, Heaven 2011 benchmark on a single card goes from 30-FPS to 9-FPS after running any CUDA task from any BOINC Project and then snoozing or shutting down BOINC client!!!

This leads me to believe it is something in the Drivers and/or CUDA SDK causing the problem.

Any help in this matter would be much appreciated. I will try to contact tech support about it as well.




Reported to tech support- Issue Reference #110515-000030

This is happening to me on a GTX 570, but it happens while in single monitor, non-sli mode. Since I do not have a second 570 in this machine I have to restart to reset my clocks rather than activate and then deactivate SLI. That was the solution I would use for my GTX 260s if they had a DTR. I too would like to find a solution to the downclocking issue. I have tried all power management settings and I can not find a solution in the control panel.

I can now confirm my two BRAND NEW EVGA GTX560 Ti cards do the exact same thing.

I also tried the 560’s without the SLI bridge attached and got the same fixed low speed clock results snoozing or exiting a BOINC CUDA task.

This was also with newly installed 270.61 drivers.


UPDATED drivers to the new 275.27 Beta and same problems on both systems.


UPDATE!!! A fix is on the way!

:::This is a quote from a reply in another forum:::

This problem has recently been drawn to the attention of the SETI CUDA developers, and is in the process of being reported onwards to other CUDA-enabled BOINC projects. It seems to be related specifically to the release of nVidia drivers which will support the forthcoming v4 release of the CUDA run-time support files. The central BOINC library code isn’t yet fully compatible with CUDA v4: the problem has been overcome with test programs, and should go away with the next round of application releases.

Unfortunately, v3 and earlier nVidia drivers aren’t available for the very latest generation of nVidia cards, but if you have a card which can run with nVidia driver 266.58, that should avoid the problem.

@ project devs:

It’s been isolated to a CUDA task exit handling problem in the BOINC API library code. Eric Korpela (SETI@home) has a copy of the proposed (and tested) solution for evaluation, and is considering checking it in following testing and evaluation. I can put you in touch with the developer concerned, or pass messages, if you wish.

So, the problem is defined and the correct folks are addressing it.