CUDA can't be enabled while Intel HD graphic card

I’m having a weird problem in my laptop. I’m using RTX 3060 with an appropriate version of CUDA and if I want to do any computation that uses my NVidia card and requires CUDA to be installed, I have to disable the integrated Intel graphic card otherwise my NVidia card will not be used in the computation.
I noticed that in Task Manager my Intel card is listed as GPU 0 and my NVidia card is listed as GPU 1. I don’t know if this is the reason why I always have to disable Intel card while computing. If so, I wonder how they can be reordered.
Thank you!

Can you check if you already have Nvidia driver installed correctly ? After that, you can check if you GPU is identified by executing $nvidia-smi.

We will close this thread in 14 days, if you still have the issue, please let us know and we will do our best to help. Thanks !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.