Cuda crash in simple application

Hello.
I have very strange error in my applications. Using cuda 4.0 and 295 drivers all work ok for along time. But about one month ago we updated drivers on 3xx and it began crashes with “unspecified launch failure” after 10-15 minutes working on any 3xx drivers(tried 304, 310, 319).
We tried any combination of drivers(304/310/319) and cuda toolkits(4.0/4.2/5.0) and all combinations crash after 10-15 minutes of working.
Now, very strange moment. They are crashes only when linux Xorg not started. When we load system in graphical mode, our application work fine and correct any time.
And so my - first question: have you any ideas whats the problem can be?

Next, I tried reproduce error in simple application. I have installed last 319 driver, CUDA toolkit 5.0. Next I launch nsight and create new “CUDA Runtime Project”. Next I did simple changes in project: added while(true) in main(). And it crashed already both with and without Xorg on my system after 20-30 minutes of working!
I get error: “Error out of memory at line 54 in file …/src/CudaCrash.cu”
My second question - why I get crash in this simple application? Attached source code: http://paste.ubuntu.com/5735200/

My system: OS OpenSUSE 12.1, 2 x GTX580 cards with 1535MBs

Based on your description of an app that used to work fine but stopped functioning correctly after a driver update (and no other changes, i.e. a controlled experiment), I would recommend filing a bug report via the form linked from the registered developer website, attaching a self-contained repro case. Thanks!

Since unspecified launch failures are often the result of an out-of-bounds memory access, have you run the code with cuda-memcheck to see whether any out-of-bounds accesses or race conditions occur?

Yes, I have run with cuda-memcheck. Its strange too, but it work fine after wrap in memcheck.
But what about my second question? It looks very strange. Standard example by nsight in endless loop crashing after 20-30 minutes of working.