cuda crash on init in lenovo t61p

Hi, i think i stumbled on a bug, when I enable dual view on my laptop, cuda crashes on the first cudaGetDeviceCount call.

here is my system info:

NVIDIA System Information report created on: 02/08/2009 13:41:44
System name: LENOVO-T61P

[Display]
Processor: Intel® Core™2 Duo CPU T7700 @ 2.40GHz (2393 MHz)
Operating System: Microsoft Windows XP, 32-bit (Service Pack 3)
DirectX version: 9.0c
GPU processor: Quadro FX 570M
Driver version: 181.20
Memory: 512 MB
Video BIOS version: 60.84.51.00.00
IRQ: 16
Bus: PCI Express x16

[Components]

nvCpl.cpl 2.2.350.00 NVIDIA Control Panel Applet
nvCplUI.exe 2.2.350.00 NVIDIA Control Panel
nvWSSR.dll 6.14.11.7784 NVIDIA Workstation Server
nvWSS.dll 6.14.11.8120 NVIDIA Workstation Server
nvViTvSR.dll 6.14.11.7784 NVIDIA Video and TV Server
nvViTvS.dll 6.14.11.8120 NVIDIA Video and TV Server
nvMoblSR.dll 6.14.11.7784 NVIDIA Mobile Server
nvMoblS.dll 6.14.11.8120 NVIDIA Mobile Server
nvDispSR.dll 6.14.11.7784 NVIDIA Display Server
NVMCTRAY.DLL 6.14.11.8120 NVIDIA Media Center Library
NVOGLNT.DLL 6.14.11.8120 NVIDIA Compatible OpenGL ICD
nvDispS.dll 6.14.11.8120 NVIDIA Display Server
NVCPL.DLL 6.14.11.8120 NVIDIA Compatible Windows 2000 Display driver, Version 181.20
NV4_MINI.SYS 6.14.11.8120 NVIDIA Compatible Windows 2000 Miniport Driver, Version 181.20
NV4_DISP.DLL 6.14.11.8120 NVIDIA Compatible Windows 2000 Display driver, Version 181.20
PhysX 8.08.18 NVIDIA PhysX
nvGameSR.dll 6.14.11.7784 NVIDIA 3D Settings Server
nvGameS.dll 6.14.11.8120 NVIDIA 3D Settings Server

Has anybody seen similar behavior ?

this also happened on older drivers.

The 570m is not CUDA enabled:

http://www.nvidia.com/object/cuda_learn_products.html

Also, it is up to the manufacturer (Lenovo) to distribute the updated drivers that would enable CUDA (were it on the list).

This a huge disappointment for me (and many others) who purchased a t61p last year and were not able to do CUDA development. I since bought a 8600gt- which promptly died on me within that same year as well. I believe there are forces in the universe preventing me from developing CUDA.

The 570m is not CUDA enabled:

http://www.nvidia.com/object/cuda_learn_products.html

Also, it is up to the manufacturer (Lenovo) to distribute the updated drivers that would enable CUDA (were it on the list).

This a huge disappointment for me (and many others) who purchased a t61p last year and were not able to do CUDA development. I since bought a 8600gt- which promptly died on me within that same year as well. I believe there are forces in the universe preventing me from developing CUDA.

you are very much mistaken, it is a g92 chip and very much a cuda enabled device. there are drivers that will install on it (usualy the ones that come with the cuda sdk) if not then you just need to edit the inf file. I have been working on this laptop (among other machines) for almost a year now, works really nice with cuda. Except for this bug, oh and only havening half a gig of ram …

Oh and look at the mobile quadro section in the page you pointed to, the 570m is there :)

Thanks- looks promising. Which driver are you using that works? I just tried 181.20 which gave me a message that it was not compatible with my hardware. Maybe only older CUDA?

as you can see from my dump im using 181.20 you just need to switch the inf file in the driver install folder. i used the laptop with cuda 1.0 2.0 2.1 all works fine except for the problem i described above.

I am trying to switch the inf file. But which one and from where to where?

Any help would be great.

The latest drivers for cuda 2.2 and beta drivers usually install without needing any modification.

Usually, but not on the FX570M with the T61p…

you can hack the inf file to get 185.85 notebook driver to install, but it wreaks havoc with presentationmanager and stability… Lenovo is just not on the ball here.

sorry about that i haven’t moved to 2.2 on my laptop. its still 2.0 with 181.20 which by the way is very stable, and works well with the presentation manager (used it in nvision for my presentation)

Just in case others have problems here too after trying 185.85 and going back to 181.20. If your presentation manager stops working, go back to the stock lenovo driver (178.xx) which repairs presenationmanager (check this after lenovo nvidia install), then install the hacked 181.20 driver. Then you should have the PM working again.

I’ve attached my hacked nv4_disp from the 181.20 install. Remember to back up your original .inf file. This is from C:\NVIDIA\WinXP\181.20\English\nv4_disp.inf. This is to install the nvidia 181.20 driver on win xp sp2 for T61p with Fx570m card. No warranty! I had to rename it to nv4_disp_inf.txt to upload it, so you’ll have to reverse that.

I just installed CUDA 2.2 on my Thinkpad T61 successfully.

If anyone cares:

  • Hardware: Thinkpad T61 with NVIDIA Quadro NVS 140M
  • OS: Windows Server 2008 (thanks, MSDN-AA ;-) )
  • Driver:
    NVIDIA Notebook Driver for Windows Vista 32-bit 185.85
    and
    CUDA Toolkit & SDK 2.2 for Windows Vista 32-bit

Presentation Manager still seems to work (I don’t use it though), so does Dual Screen and Standby

  • no bluescreen so far.

Softwarewise, I had to run one CUDA test application as administrator after boot, but afterwards
could run everything as normal user.
Except some issues with D3D9&10, the CUDA examples worked fine.

UPDATE:
Since installing NVidia drivers 185.85, I cannot set LCD brightness any more - neither with
Fn+Keys, nor through Windows’s or Lenovo’s Power Manager.
To change brightness, I have to reboot, change brightness with function keys during bootup.
After nvidia drivers are loaded, it’s no longer possible to change it.

Anyone has any insight into this?

*** How to make the driver installer recognize your card:

Before installation, the inf-File needs to be patched, otherwise, the NVS 140M is not recognized.

  • Unpack the cudadriver package and edit Display\nvdm.inf
  • Look for “%NVIDIA_DEV.0429.01% = Section001, PCI\VEN_10DE&DEV_0429&SUBSYS_01FE1028”
  • Change the SUBSYS_xxxxxxxx ID to the one you find in your device manager for your Graphics card.
    (For me, it was 20D817AA)

The Installer should now find your card.

Have fun,

Matthias

Thank you so much for sharing this info! :thumbup: By following similar method, I installed CUDA 2.2 on Levono T61p with FX570M.

The change that needs to made is in Display\nvbl.inf:

Change line:

%NVIDIA_DEV.040C.01% = Section002, PCI\VEN_10DE&DEV_040C&SUBSYS_30C5103C

To:

%NVIDIA_DEV.040C.01% = Section002, PCI\VEN_10DE&DEV_040C&SUBSYS_20D917AA

Here 20D917AA is the subsys version I found in the Device Manager of windows.

I have no problem in presentation manager or the screen dispaly of lightness. I do have the latest version of power manager and presentation manager installed. If you download the latest version of these managers from Lenovo, you can fix your problem.

:rolleyes:

This thread was really helpful to me as I struggled to get the 190.89 (OpenCL enabling) driver installed on my Lenovo T61p with the Quadro FX 570M GPU running Vista32 SP2.

Thanks to all who contributed.

However, I think the “method” can be described slightly more generally and this is what I’m going to try to do. Each of these people clearly did something along the lines of what I’m going to say, but I don’t think they fully revealed what they did and I had to read between the lines a bit. I just though I’d document that.

  1. Download what looks to be the right driver from nvidia for whatever you are trying to do
  2. Start the installation of that driver in the normal way
  3. Make a note of where it tells you it’s going to unpack the driver. In my case, it was c:\NVIDIA\DisplayDriver\190.89
  4. In what follows, I assume that the driver fails to install and that you get some error about not finding a driver for you hardware etc. Cancel. (If it did not fail, then you do not need what follows).
  5. In explorer, go to the unpack location and from there into the International subdirectory (in my case)
  6. In the explorer window, use the “search” field at the top right to look for your GPU by name: “Quadro FX 570” in my case
  7. It will fail to find it but will offer you a “Search in File Contents” button… push it.
  8. You’ll (hopefully, if your hardware is supported by this driver) see a few files but one with a name like nv?? where ?? will be 2 or 3 letters (I don’t know what those letters mean)
  9. Open that file in “notepad”
  10. Look for that GPU string name in that file (it’ll be toward the bottom).
  11. Make a note of the text to the left of the equal sign corresponding to you GPU’s entry
  12. From the top of the file, search for that string: It’ll be something like NVIDIA_DEV.040C.01
  13. When you find it, it’ll be in a line like
    %NVIDIA_DEV.040C.01% = Section003, PCI\VEN_10DE&DEV_040C&SUBSYS_#########
  14. The digits at the end (########) are the ones you must tweak
  15. Open the control panel and put it in “classic view”. Double-click on the “system” icon and then pick the “Device Manager” from the upper left list (give permission if and when prompted).
  16. Open the Display Adaptor and double click on you GPU entry below that.
  17. Go to the details section and select “Hardward Ids” in the property selector
  18. You should see at least one entry that ends with SUBSYS_######### (in my case, SUBSYS_20D917AA). Make note of this final number
  19. Take that final number/string and replace the string you found in the nv?? file with this new hex number (string)
    So that line in the nv?? file will look like
    %NVIDIA_DEV.040C.01% = Section003, PCI\VEN_10DE&DEV_040C&SUBSYS_20D917AA
    in my case.
  20. Run the Setup.exe in the directory to which the driver was unpacked (the one that contained the nv?? file you changed) and that should install perfectly.

I believe these steps will work in general where you change the stuff that is specific to my host to what is correct for you (and I hope that is clear from what I’ve written). I’m sure lenovo would frown on this, but without this change, my laptop would now be scrap.

Good luck.