cuda cross compilation setup

I am trying to cross compile cuda sample on my host and device both running ubuntu 14.04 and cuda 6.5. My host is running on a virtual machine on windows 8 platform. I couldn’t locate post installation steps for cuda cross compilation for cuda 6.5 ( i have already set the path and copied cuda lib and binaries from device ( Jetson Tegra K1 ) to host. Now I am trying to build a sample program on my host machine on NSight but I am getting following message:
Building target: boxfilter-arm
Invoking: NVCC Linker
/usr/local/cuda-6.5/bin/nvcc --cudart static -L/usr/local/cuda/samples/common/lib/linux/armv7l -Xlinker --unresolved-symbols=ignore-in-shared-libs --relocatable-device-code=false -gencode arch=compute_20,code=compute_20 -gencode arch=compute_20,code=sm_20 --target-cpu-architecture ARM -m32 -ccbin arm-linux-gnueabihf-g++ -link -o “boxfilter-arm” ./src/boxFilter.o ./src/boxFilter_cpu.o ./src/boxFilter_kernel.o -lGL -lGLEW -lX11 -lXi -lXmu -lglut
/usr/lib/gcc-cross/arm-linux-gnueabihf/4.8/ /arm-linux-gnueabihf/bin/ld: cannot find -lX11
/usr/lib/gcc-cross/arm-linux-gnueabihf/4.8/ /arm-linux-gnueabihf/bin/ld: cannot find -lXi
/usr/lib/gcc-cross/arm-linux-gnueabihf/4.8/ /arm-linux-gnueabihf/bin/ld: cannot find -lXmu
/usr/lib/gcc-cross/arm-linux-gnueabihf/4.8/ /arm-linux-gnueabihf/bin/ld: cannot find -lglut
collect2: error: ld returned 1 exit status
make: *** [boxfilter-arm] Error 1

Please guide me what am I missing?

Note: I get the same error for all sample programs. Which means I am missing some setup…


Hi, I also encounter the same error . Can you share how you solved it ?