CUDA. CuDNN, OpenCV unavaliable after installing Jetpack 5.1.1 on Xavier NX

I have successfully flashed Jetson Linux and installed the Jetson Runtime components on 16GB Nvidia Xavier NX but cannot import CUDA or OpenCV from terminal. Please check the SDK Manager Log file.

SDKM_logs_JetPack_5.1.1_(rev._1) (228.7 KB)

Here are some of things which I tried so far:

$ apt show libopencv-python
Package: libopencv-python
Version: 4.5.4-8-g3e4c170df4
Priority: optional
Section: libs
Installed-Size: 12.0 MB
Provides: python-opencv
Depends: libopencv (= 4.5.4-8-g3e4c170df4), libc6 (>= 2.17), libgcc-s1 (>= 3.0), libstdc++6 (>= 9)
Conflicts: python-opencv
Replaces: python-opencv
Download-Size: 3,201 kB
APT-Sources: r35.3/main arm64 Packages
Description: Open Computer Vision Library
 Python bindings for Open Source Computer Vision Library

Also the $PATH and $LD_LIBRARY_PATH in .bashrc is configured properly however there is no bin folder in /usr/local/cuda-11.4.


Is the JetPack components installed with SDK Manager? It does not seem to be installed completely.
Please try to remove it and install it again:

sudo apt autoremove nvidia-jetpack
sudo apt install nvidia-jetpack

Also, if it’s installed correctly, python should be linked to Python 3.x, whereas it’s python2 for Python 2.x.

Thanks for your response. I have re-flashed only Jetson Linux using SDK Manager and JetPack using the above mentioned commands. However, I face the no space left on device error.
How can I only install runtime libraries?


then you may just install nvidia-jetpack-runtime if you only need runtime libraries.

I have only installed the runtime libraries now but the error seems to be the same. Just for your reference, I am using custom development board with GB Jetson Xavier NX Module.

Or shall I use this command:

apt depends nvidia-jetpack | awk '{print $2}' | xargs -I {} sudo apt install -y {}

Well, runtime libraries are not intended for coding…

This command does not make much difference than directly installing nvidia-jetpack

apt depends nvidia-jetpack | awk ‘{print $2}’ | xargs -I {} sudo apt install -y {}

They both require more than 5GB of disk space.

If you do need the JetPack libraries but run out space, I’d suggest swap for a larger SD card for the SD card version of Xavier NX, or install an NVMe SSD drive and re-flash the device to use the SSD for rootfs.

I removed the Jetpack using

sudo apt autoremove nvidia-jetpack-runtime 

and have around 7GB of free space. Do you think this much is enough to install full version of Jetpack ?

I think that’s enough.
It’s around 5GB of disk usage on my side.

I have tried to install Jetpack again but still left with no space and terminal shows below error:

When I tried to remove Jetpack got this error:

Please help me in solving this issue.

Well, not sure why it does not work on your machine…
Did you try

apt --fix -broken install

or maybe

sudo apt purge nvidia-jetpack

If you really cannot find a larger storage device for rootfs, maybe you can run

apt depends nvidia-jetpack-runtime
apt depends nvidia-jetpack-dev

, and install only specific packages that you need.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.