Cuda Debugger crashes Visual Studio

On my gtx570 machine, when debugging cuda code in visual studio, the visual studio disappears when i start cuda debugging. Where are the crash logs? anybody else know what happens - ie why it disappears. I have a 4.0 Nsight, 352.86 driver.

A long time ago, when i had an older driver and an older Nsight, I was actually able to use the cuda debugger. The Nsight version is as far as i can take it for my machine (which is 4 yrs old) and the version of Visual Studio I am using.

any suggestions?
thanks

Hi

Could you update Nsight to the latest version 4.6 and try again? Your driver is new enough but Nsight is out of date. Thanks.

Qian

Hi

I am limited to go upto nsight 4.0 as i am using visual studio 2008.

But it does not have anything to do with nsight since i was able to get other cuda projects working/not crashing with nsight 3.2 and visual stuido 2008.

Do you know where the logs or any logged information go when the crash happens? It says c:\temp but i cannot find anything there with the right timestamp.

When the crash happens, i can see the Nsight Monitor , it says it is properly configured for Nsight GPU debugging and analysis but under connection , it says (no connections).

Under Nsight Monitor options, I see the following field values:
Monitor port 8000
WDDM TDR Enables False
Driver instrumentation enabled False
Enable per machine permisiions False
Enable secure connection False
Report Directory c:\temp

Desktop GPUs must use software preemption True
Headless GPUS must use software preemption True
TCC GPUS must use software premption False
Use this Monitor for Cuda to attach False

So where are the logs being written so i can do a quick peek at the last recorded error?

thanks!

Just to be clear: I dont think it is Nsight 4.0 is the problem. Since older versions of Nsight work. Unless there is something in the Nsight 4.0 version specifically that you know of.

Hi,

For error log of VS2008, you could launch Visual Studio 2008 Command Prompt and type "Devenv.exe /log ". Then the log files will be generated in the .

Another probable way is revert your driver to the old one. Recommened driver for Nsight 4.0 is 332.59.

I still strongly recommend you to update your VS and Nsight. We have dropped VS2008 support for a while. VS2013 community is supported by the latest Nsight and it’s free. It could set platform toolset to v90.

Thanks.
Qian

C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE*\msenvui.dll


10
2015/06/27 04:48:16.344
Error
Microsoft Visual Studio
Error checking App Path


80070005 - E_ACCESSDENIED

what does this mean? i cannot find a msenvui.dll in my higher visual studio editions either. Does this mean that even if i upgrade to a higher visual studio version, the error will stay?

also i could not find 332.59. the lowest driver i found was 334.XX. Do you know where i can get 332.59?

The reported error is not about msenvui.dll. msenvui.dll entry is enclosed by . Error exists in record 10. Seems like your application is not accessible or it doesn’t exist. I’m not sure since I’m not the expert of VS. Anyway, it’s not a Nsight related issue. Please check your project.

Driver 334.xx should work well. What’s your result with it? Thanks.

Qian

Hi

Update: It is not a problem with Visual Studio. The reason is that I am able to load Visual Studio even with the error. I was doing devenv.exe /log “crash.txt”. In the crash.txt, before crashing, I am able to see the error before running Start Cuda Debugging.

Only after I launch Nsight’s Start Cuda Debugging, it crashes.

Driver 334.xx and Nsight 4.0 makes no difference. I was looking at Nvidia’s Nsight Errata/Known bugs and I came across this:
Fermi devices with an attached display can hang when stopping debugging while at a breakpoint. This occurs in hardware mode debugging. Please use preemption mode debugging, or switch to a GPU without an attached display. (18778)

My machine is a Fermi.

Just to let you know that the following things are turned on:

Desktop GPUs must use software preemption : True
Headless GPUs must use software preemption: True
TCC GPUs must use software preempton: False
Use this Monitor for CUDA attach: False

All these settings appear correct to me. Use preemption mode debugging - where do i turn that on?

You are already in preemption mode because Desktop GPUs must use software preemption and Headless GPUs must use software preemptio are set to true.

I don’t think your situation matches that know issue. It’s machine hang when debugging. While yours is VS crash.

Is it possible to get your project and let me try on my side? At the meantime, could you try to update your VS and Nsight? Thanks.

Qian@nvidia

How do you want me to send you my project? zip and send to an email you shall provide?

Give me your email address and I will send you an FTP site to upload. Thanks.

It’s attached to my account. Can you not access it? Anyways, its minidrive.lala@gmail.com

Hello qzhang,

Are you going to send me the ftp link?

thank you

I have sent you the ftp link at Jul 13th. I’m also curious why I haven’t got your any response. Anyway, I send it again. Please ping me if you still don’t receive it.

BTW, is it possible to filterd to your junk folder? Just a reminder. Thanks.