CUDA Developer Driver on Geforce GT 630M w/ Fedora 16

I’m trying to install the developer drivers on my laptop, which has the Core i7-2670QM Sandy Bridge Processor and a GT 630M. Here’s the one I bought: http://www.amazon.com/N53SM-ES72-15-6-Inch-Laptop-Silver-Aluminum/dp/B007BY57Y2/ref=sr_1_1?ie=UTF8&qid=1337136107&sr=8-1

I’ve done a full installation of Fedora 16, with no dual-booting.

Here’s what I find when I execute ‘lspci | grep -i VGA’
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 0de9 (rev a1)
Notice that even though an nvidia card is listed, it cannot name it.

I’ve attempted to install the developer drivers with a mixture of the following guides:
http://www.if-not-true-then-false.com/2011/fedora-16-nvidia-drivers-install-guide-disable-nouveau-driver/
http://geek.co.il/wp/2011/11/15/installing-nvidia-drivers-on-fedora-16-the-wrong-way

I want to know if my card is even supported by the developer driver and if I should just return the laptop.

I have ran the installer, but when I reboot, GNOME will not load up.

Hello,

If got it right your laptop has optimus. Just installing the nvidia driver directly wont work.

So in order to install CUDA you will need to install bumblebee to get the optimus running (the nvidia driver is installed together) with it. After this the cudatoolkit can be installed. The programs are compiled like usually nvcc code.cu and then you run the programs with optirun ./cudaexecutable

The other way is to go to BIOS and see if yould disable the intel integrated graphic card. After everything will be like usual install.

I tried that, same results. Here’s what I did:

Installed bumblebee with the following guide: https://fedoraproject.org/wiki/Bumblebee

Blacklisted nouveau with this guide: http://geek.co.il/wp/2011/11/15/installing-nvidia-drivers-on-fedora-16-the-wrong-way

init 3, login as root, and ran the installer.

Rebooted, X server fails to start.

Here’s the resulting xorg.conf file generated in /etc/X11 by the driver installation.

Am I missing something here?

The x server has to run on the intel gpu not on nvidia. After the nvidia driver is intalled you are not supposed to run the nvidia-config. I do not know how is it done in fedora I only did it on ubuntu laptop with optimus. The general idea is the same the Xserver runs on the intel gpu.