CUDA Development Drivers with OPTIMUS (Intel HD 3000 and GEFORCE GT 520M 1GB) on my ASUS U31SD-AH51

Will I be able to do CUDA development? I bought this specifically to experiment with parallel processing . Can it use the NVIDIA GEFORE GT 520M’s CUDA cores in development? Will I still be able to make software in say, Java, C++, Ruby, Python, or Perl that can attach to CUDA bindings through the development drivers?

Yes, you can do the CUDA development in the NVIDIA GEFORE GT 520M graphics card. may be some time the OPTIMUS driver will not switch to application to run in NVIDIA GPUs automatically. In that case you have to select the High Performance NVIDIA processor from the context menu (Right Click on application). In most cases the Optimus will automatically select the NVIDIA GPU for GPU computing application.

I have a problem regarding something related to this topic.

I have following system config:
Maker: Sony
Model: Vaio
OS: Win 7 64-bit (Japanese)

  1. Intel HD Graphics 4000
  2. Nvidia GeForce GT 640M LE

I recently installed Cuda dev toolkit to start some development using parallel architechure.
I installed the latest toolkit that comes for Win7 64-bit Notebook from NVIDIA site.
Installation went smoothly and even updated latest drivers (320)
After doing all this, when I tried to find out the number of cores and memory stats
using the sample code (DeviceQuery) provided in the toolkit the program says
no cuda enabled device detected …

So I was wondering if it has something to do with NEW Optimus technology or any other

Any kind of help or suggestions regarding getting these sample programs working will
be appreciated !!

Maybe you need to specify to run on nvidia. Doing right click on the exe you will have additional option like run and run on nvidia. Otherwise you can also set in the nvidia driver that some programs will always run on nvidia.

I tried the right click but the option to run on nVidia is disabled.

Secondly, I am not sure about how to set the nVidia driver to run any program on it.

Is your card active? Check the BIOS option to see if the card is disabled?

Yes I think my card is active as I can see it in Device manager as well as in system info displayed by using msinfo32.
In system info I can see 2 graphics devices

  1. Intel HD Graphics 4000
  2. Nvidia GEForce GT640M LE

I think the problem is with automatic switching technology (Optimus) that is not allowing CUDA samples to see the Nvidia card.
Was trying to figure out a way to bypass or disable this…

I have the same problem. I wonder if you found a way to resolve it? Thanks!