Cuda deviceQuery errors

Hi all. I’m trying to get CUDA up on my machine to use with MXNET in python. I had installed CUDA, and MXNET, but was getting an error from python telling me no GPU was detected.

After doing some digging, I think that my CUDA install might not be working correctly.

I’ve downloaded CUDA 9.2 and installed and patched it. I’m building the samples library using Visual Studio 2017.

When I rebuild the samples, I get the following message:
========== Rebuild All: 41 succeeded, 122 failed, 0 skipped ==========

I’m not sure that those should all be succeeding but that seems like it possibly indicates a problem?

When I run the deviceQuery.exe sample, I get the following output:

deviceQuery.exe Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 30
-> unknown error
Result = FAIL

Obviously this isn’t very helpful. Does anyone know what I can try in order to get this working?

Specs / Other info:
Windows 8.1 PC, Intel CPU
Geforce GTX 760 GPU
Fresh install (today) of both NVIDA drivers and CUDA 9.2
Have restarted computer multiple times.

what driver version did you install?

does your GPU show up in windows device manager with no issues?

The card shows up in device manager. I tried driver 419.67 (latest download on nvidia drivers page) as well as 398.36 (pre-cuda 10 release) with the same problems appearing with both sets of drivers.