CUDA driver 179.48 on Dell XPS M1730 (GeForce 8800M GTX) cannot run Matlab AccelerEyes' Jacket

After installing CUDA driver 179.48 driver on a new Dell XPS M1730 with NVIDIA GeForce 8800M GTX and CUDA toolkit 2.1, I tried Matlab (2008a)AccelerEyes’ Jacket. This is what I get

ginfo
Jacket v1.0.1 (build 541) data: 0 CPU-used, 0 GPU-used, 448 GPU-free (in MB)
GPU0 (enabled) GeForce 8800M GTX, 1220 MHz, 511 MB VRAM, Capability 1.1

So, it should be OK. However, trying a verification sequence,

a = gzeros(1024,1);
gforce(a);
a = a+ 1;
gforce(a);
b = double(a(1:10));
Jacket:445(cubin_subsref) CUDA error: global function call is not configured
??? Error using ==> gpu_entry
GPU failure (save your work and restart Matlab) (Jacket:445)

According to AccelerEyes’s support, the above error listing indicates the correct driver has not been installed. However, I was able to successfully run bandwidthTest, specified in

http://www.techfuels.com/cpu-components/12…stall-cuda.html
AND
CUDA_2_Quickstart_Guide.pdf

Has someone epxerienced the same (or similar) problem? Which drive should be used to get the AccelerEyes’ Jacket running?

Hi sstoyanov1970,

I am having the same issue. I was running CUDA 2.0 with the Jacket 0.6 eval version - that version worked ok. I upgraded to Jacket 1.01 and realized that they only support CUDA 2.1. I tried to install the recommended 181.20 driver but that driver does not support my 8700 GT card so I went with the latest 179.48 driver and installed 2.1 toolkit and SDK. Now the CUDA examples no longer run and Jacket still gives me the “GPU failure” error that you listed below.

I am contacting AccelerEyes about backward compatibility with CUDA 2.0.

Let me know if you get any where with this.

–seh

Sstoyanov1970,

I looked into this a bit more and found a work around that is working on my XPS1730. It turns out that nVidia has excluded support for the 8700M from the 181.20 driver.

http://www.laptopvideo2go.com/drivers has a modified version of the 181.20 and a “modded inf” file that can be downloaded to manually install the driver. I carefully followed their instructions for the “Have-Disk Install” and was able to update the video driver to the modified 181.20 version that I downloaded. I then reinstalled CUDA 2.1.

This is the page that I got the drivers and instructions for the Windows XP 32bit:
http://www.laptopvideo2go.com/drivers/xp/181.20

The nVidea CUDA 2.1 examples work properly now and the Jacket filter2_example seems to be working in Matlab.

I hope this works for you.

Good luck.

–seh–

SEH

Eternally grateful!

Sstoyanov1970