CUDA Driver 2.3 hangs on Ubuntu-64/Acer laptop

After upgrading Ubuntu to 9.04 and installing new CUDA Driver v.2.3 my Acer Aspire 5920G have a dead black screen after X server start.

X-server log file contains no errors, also restoring old Xorg.conf makes system working (but without CUDA, of course).

System parameters:

  • Acer Aspire 5920G / GeForce 8600M GT
  • Ubuntu 9.04 kernel 2.6.28-13
  • CUDA Driver 190.16 for Linux 64

I’m not skilled in Linux and don’t know how to investigate this more. Do anybody use similar configuration?

Yes, it’s a known bug specific to laptops. See this thread.


there’s a known bug with laptops that will be fixed with the next 190.xx driver release (should be soonish).

Hi Tim. Does this mean it isn’t fixed in 190.18? I was just about to give that one a try, but I’d like to save myself the trouble if the fix isn’t there :)

UPDATE: Well, I tried it anyway, and it looks like the 190.18 beta is working for my laptop. Thanks Nvidia! :)


Thanks, will be waiting for it :)

apparently that driver is 190.18–I had no idea it was out already. yeah, use that and laptops will work.

use that and laptops will NOT work. I have an Asus M50VN (9650M GT with 1GB VRAM) and nothing beyond the 180.xx series of drivers has ever worked. Optimistically installed 190.18, logged in and after a few seconds heavy screen flickering makes the system unusable. Keyboard does not work, mouse is dead, impossible to switch to a virtual console. It is even impossible, to log in to the laptop via LAN from another machine and pinging the laptop elicits no reply. Distro is OpenSuSE 11.1 64-bit, kernel is The driver works like a charm on a desktop with 2 GTX-260. The software installed in the laptop and the desktop (in terms of installed packages) is absolutely identical. This laptop is the only reason, why I keep CUDA 2.1 around. None of the CUDA 2.2/2.3 drivers so far has worked on the laptop.

Thanks, as for my Acer 5920G - it works!

With NVIDIA driver 190.18-beta I managed to build and run SDK 2.3 examples on Ubuntu 9.04.

One hint:

Be aware of feature/bug of Ubuntu 9.04: it is only possible to set LD_LIBRARY_PATH value in the ~/.bashrc file.

If you set LD_LIBRARY_PATH in /etc/environment , /etc/profile or ~/.profile you will not see it (