CUDA Driver

Hello,

I’m trying to use YOLO with my jetson agx orin developpement kit.
“But I have this error: CUDA failure: CUDA driver version is insufficient for CUDA runtime version in file yoloPlugins.cpp at line 160
Aborted (core dumped)”

Do you have any idea to solve this problem ?

Astrid Duban

Hi,

Have you manually upgraded the CUDA version?
Or do you meet the error with the default package contained in the JetPack?

Thanks.

Hi,
I did it manually but I have several folders in /usr/local: cuda, cuda-11, cuda-11.4, cuda-12, cuda-12.2 and I don’t know how to delete them. I think the version used is 12.2.

sudo gedit ~/.bashrc
export PATH=/usr/local/cuda-12.2/bin${PATH:+:${PATH}}
export LD_LIBRARY_PATH=/usr/local/cuda-12.2/compat${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}

Cuda for jetson not upgrade drivers like cuda for gpus. Wait for jetpack 6.0.
You have all here to use last models: Start with Jetson AGX Orin Developer Kit. - HackMD
Also, I recommend jetson-containers

Hi,

Please try to export the compat folder (as johnnynuca14 mentioned).
Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.