Cuda failure: status=801 Error(-1) in buffer allocation

Wait a minute, I will simplify the code and keep the core code

I have tried your code on my GPUs(L4 , T4 and A2), It works fine.

You can try use docker.

docker pull

otherwise reinstalled the driver and system ?

Sorry, this business does not work with docker, and the cost of resetting the environment is relatively high. Currently it seems that my machine environment has no problem running deepstream_test1. My custom code runs without problems on your machine, but on my machine An error is reported when running. Can you help analyze the possible reasons? For example, machine operation and maintenance has made some configurations at the bottom of the machine? Or virtualization, etc.?

deepstream-app version 6.3.0
DeepStreamSDK 6.3.0
CUDA Driver Version: 12.2
CUDA Runtime Version: 12.1
TensorRT Version: 8.5
cuDNN Version: 8.8
libNVWarp360 Version: 2.0.1d3

My software version is above. update the cuDNN to 8.8 ? I also suggest you reinstall step by step.

I don’t have a A40 GPU, so I can’t sure if this problem related with hardware.

OK, I’ll try reinstalling.
I have another question. In “dGPU Model Platform and OS Compatibility” you list A10, A30, and A100. In theory, the A40 should also support deepstream, right? I can run 6.3deepstream_test1 on the A40 but cannot run my custom python code. I’m confused about this, could this be a bug?

By the way, what is your graphics card driver version?

Driver Version: 535.86.10

Ok,thank you so much

I have two more questions that I hope will be answered:

1.When I installed components according to the official tutorial, an error occurred when installing ‘librdkafka’. I skipped it and then continued the next installation. Will this have any impact?
2.The operation and maintenance colleagues have performed virtualization operations on the A40. I wonder if it is this vGPU that causes the program to fail to run normally?

Unless you use msgbroker, otherwise no impact.

I am not sure,I have not used gpu virtualization

ok, i understand, thank you for your reply

Hi,i found that I run normally, but when I run, an error is reported. The exception log is as follows. Maybe it is a problem with a certain component in the code?

multistream_log.txt (2.2 KB)

Can also run normally?

If yes, as your metioned above, are you use vGPU ?

Maybe there are some trick i did not tried.

You can try Enabling Unified Memory for a vGPU

1 Like

Yes, the test2 log is beyond the scope of the display, so I only intercepted the last paragraph, it seems that it is also running normally
test2_log.txt (866 Bytes)

Thank you very very very much for your inspiration. I have already asked my operation and maintenance colleagues to investigate. I seem to have seen the dawn of victory.

You are awesome, thank you for your help, the problem has been solved, it is indeed a unified memory problem, thank you again