cuda-gdb won't break in kernel

I’m running CUDA_2.3 on Fedora 10. My machine has a single GTX 280. I am running at runlevel 3 (i.e., no X server is running). I compile a simple application with “nvcc -g -G -o app”. When I run “cuda-gdb app”, I can set a breakpoint at a GPU kernel by name (so it has the symbol), but it never actually hits the breakpoint when I call the kernel.

One error message I see when I run in this mode (no X server) is “ACPI Exception (utmutex-0263): AE_BAD_PARAMETER, Thread C3A8C010 could not acuiqre Mutex [1] [20080609]”. I get this message if I run a CUDA program from the command line or within cuda-gdb. I’m not sure whether or not it’s relevant. The message is not too surprising, because I have “pci=noacpi” and “acpi=off” in my linux kernel boot parameters.

Any ideas what is going on?

EDIT: Whoops! The problem was the code I was actually testing on was compiled to .o files then linked, and I was missing the debugging parameters on the link line. All good now, I think.