CUDA grid launch failed error for gtx1080ti, vs2015, win10, nsight5.2

I followed the tutorial
to try to debug the sample project.
Here are some problems I encountered on gtx1080ti, vs2015, win10

  • NSight will ignore all break points in release mode.
  • The NSight will ignore the second break proint in the turorial in debug mode. At the same time, the NSight monitor will report a warning "CUDA grid launch failed"
  • I tried to debug some other sample project such as the cdpSimpleQuickSort. Nsight moniter reports that "CUDA Dynamic Parallelism debugging is not supported in preemption mode. Breakpoints will be disabled. "

Here is the error list and the driver is running in WDDM mode.

CUDA context created : 2bfa3680770
CUDA module loaded: 2bfabd65b40
CUDA grid launch failed: CUcontext: 3022103512944 CUmodule: 3022244961088 Function: _Z13matrixMulCUDAILi32EEvPfS0_S0_ii
CUDA context destroyed : 2bfa3680770

I tried to reinstall my OS and used three versions of graphic driver, but the same problems are still existed.
The driver versions are 382.33, 382.05 and 381.89.

Hi EternalSaga,

It’s a known issue, we already have a bunch of bugs to track it, hope it will be fixed in next version.

Best Regards

OMG, this issue has confused me for 10 days! GTX 1080 ti is a 3 months old graphic card but you still haven’t solve this bug.

Here is an another bug I found in my situation.
cudaDevice* series functions will caused application crush in debug mode.


Could you provide your src, then I can try to repo it on my computer

Thank you very much. At present, I turn to my work to gtx780ti temporarily.

BTW, if you want to debug the cdp cases, you must use your second GPU, “CUDA Dynamic Parallelism debugging is not supported in preemption mode” means you cannot debug the cdp cases on display card with software preemption, you muse use your second GPU and disable the software preemption on it.

Of course you cannot debug the release build, it doesn’t have any debug info.

CUDA grid launch failed is a known issue