CUDA installation failed. No reason given

I am trying to install CUDA 8.0.61 on Windows 10 x64. I have tried using both the full 1.3GB download, and the network install. However, both attempts have ended in failure, with no reason given, just this list of failures.

  • CUSPARSE Development 8.0 Not Installed
  • Sampled 8.0 Not Installed
  • Visual Studio Integration 8.0 Failed
  • NPP Development 8.0 Not Installed
  • CUSPARSE Runtime 8.0 Not Installed
  • nView 148.03 Not Installed

The rest of the list says Not Installed.

Visual Studio 2015 Community Update 3 is installed. However, I previously had VS2017 installed, but I uninstalled it, and installed VS2015. Perhaps there is some residue of VS2017 that’s confusing the CUDA installer? Looking in Control Panel, I can see parts of VS2017 still listed, though when I try to uninstall them, it says: “Error, it may have already been uninstalled”.

I believe I need to install this to do OpenCL development in Visual Studio. What can I do to get past this?

Hugo

The problem seems to be the Update 3. CUDA 8.0 needs Visual Studio 2015, with no updates.

To remove the update, go to Control Panel -> Uninstall Programs -> Uninstall an Update. Scroll down to find Update 3 for Visual Studio 2015, and uninstall it.

When I re-tried the install after that, it worked. (Also, I made sure to reboot after every install / uninstall step).

Um…interesting, looks like I should fill a bug to dev

Hi,

I can install it on vs2015 update 3, maybe the error comes from vs2017