CUDA Installation on 2013 Macbook Pro (NVIDIA GeForce GT 750M) - Driver version incompatibility

Hi Guys,

As the title says, I wanted to install CUDA on my Macbook pro. I know my compute capability is low (3.0) for my GPU (NVIDIA GeForce GT 750M) but it’s more so for me to get introduced to CUDA programming.

I have been following the instructions outlined here (https://www.quantstart.com/articles/Installing-Nvidia-CUDA-on-Mac-OSX-for-GPU-Based-Parallel-Computing) and am at the point where I run deviceQuery.

I get the following error:

./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

My CUDA toolkit version is 9.0? My GPU driver version is 355.11.10.10.15.102 (if that is the right number). Are these two not compatible?

Thank you for your help!

Hello pratik.saripalli,

What is the version of your OS ? What is your CUDA Driver Version ? (You can find the latter in “CUDA”, in the “System Preferences” app of your Mac.) Someone (me included) is experiencing troubles on macOS High Sierra (10.13.1 (17B48)), MacBookPro10,1 (Retina, Mid 2012), with the new drivers for CUDA capable GPUs (CUDA Driver Version 9.0.222; NVIDIA Web Driver 378.10.10.10.20.107), hence troubles with CUDA in general, since the CUDA GPU is not usable. At the moment, I can’t use apps that use CUDA, nor can I compile (this is also because of a version of Command Line Tools (9.1) that is too recent for the Cuda compilation tools), nor run any CUDA code/app.

At the moment, I don’t even know if we can compile and run our CUDA code on High Sierra, since the last compilation tools (release 9.0, V9.0.175) are specific to macOS 10.12 (Sierra). Should we wait for the next Compilation tools ? Anyways, I have decided to install Sierra on an external drive and use it just for CUDA development.

You can follow a discussion here https://devtalk.nvidia.com/default/topic/981823/cuda-setup-and-installation/cuda-still-shows-as-quot-update-required-quot-after-installing-latest-package-for-macos/4/?offset=59#5221875, with further details on mine and other’s configuration.

Thanks to all the community, you guys have a nice day.

HI Pvag,

Thank you for the reply. I am on High Sierra, 10.13.1. CUDA version is 9.0.222. It says update required but there is no update that I can download (I can’t click on the button). I actually saw that thread and my next step was to follow the solution one poster in that thread posted (https://devtalk.nvidia.com/default/topic/1025945/cuda-setup-and-installation/mac-cuda-9-0-driver-fully-compatible-with-macos-high-sierra-10-13-error-quot-update-required-quot-solved-/). I think he decided to downgrade the CUDA version? I haven’t read through it but have you tried it?

Thanks!

Yes, I have tried that solution, but with no success; thank you for sharing it, anyways! He says that you should uninstall Apple’s native GPU Driver and install NVIDIA’s Web Driver, instead. That may work (it doesn’t, on my computer), if you need to only run CUDA code, but I believe you will not be able to compile CUDA code though, unless you will install the Command Line Tools for the old Xcode (I think it is version 8.something) - I don’t know if High Sierra will allow you to do that! Furthermore, it is explicitly stated in section 1.1. System Requirements of the NVIDIA CUDA Installation Guide for Mac OS X (http://docs.nvidia.com/cuda/cuda-installation-guide-mac-os-x/index.html) of the CUDA Compilation tools 9 that your os should be 10.12 (Sierra), your Xcode 8.3.3 and your Apple LLVM 8.1.0 . This is why I am going back (on an external drive) to Sierra, for now.

For anyone interested: from the App Store (here) you can still download macOS Sierra - you will find it in your Application folder.

Ah I see. I guess I will have to follow your suggestion. Let me know if you have success.

Yes, it works perfectly ! High Sierra with no CUDA support on my main hard drive; Sierra with full CUDA functionalities (compile, run, etc.) on my external hard drive ! (Xcode 8.3.3, Command Line Tools 8.3.2, CUDA Drivers 9.0.222 (automatically installed), macOS Sierra 10.12.6) I press alt at boot time, select the partition with Sierra on the external hard drive and boot from there: it works flawlessly. I tried other solutions listed here on the forum, but this one is the only one that worked, for me.

I believe this is a good, solid solution, while we wait for driver updates from Apple/NVIDIA and for a new Cuda Toolkit.

If you are interested in this solution, let me know, so that I will write a post about tips to follow for smoother operations overall.

P.S. Of course, you will have a slower system, if your external hard drive has a USB 2.0 interface (I haven’t tested the speed of other interfaces, like USB 3, though: that may be not so slow!): every time your OS will need to write to disk it will probably be way slower than what you are used to, but not impossibly slow, of course ! Booting requires 2 minutes, instead of 30 seconds, for example.

[SOLVED]

I wanted to update anyone interested, that I was able to make the Web Driver finally work (see previous posts of mine to see which hardware I am running it onto), just by setting:

  • System Preferences -> Energy Saver -> Automatic Graphics Switching: Off (untick)
  • System Preferences -> Energy Saver -> Computer Sleep: Never

installing***:

  • Mac OS High Sierra 10.13.4
  • Xcode 9.2
  • Command Line Tools for Xcode 9.2 (Mac OS 10.13)
  • CUDA Driver Version: 396.64 **
  • NVIDIA Web Driver: 387.10.10.10.30.106 **
  • CUDA Toolkit 9.2
  • CUDA Toolkit CUBLAS Patch 9.2

Now my MacBook Pro 10,1, equipped with a GeForce GT650M, can compile* and run* CUDA programs.

  • In order to make this work, you have to set the PATH and LD_LIBRARY_PATH environment variables accordingly to the location specified by NVIDIA in the Installation Manual.

** In one or both (or only one, I don’t remember exactly) of these steps I had to authorize the driver (under the “Allow apps…” section) developed by NVIDIA in the “Security & Privacy” section, under System Preferences. I believe this was the step I was missing during my previous attempts and was making the machine stuck at boot time, after a restart, after selecting the Web Driver. I hope this can help people in the same situation !

*** You can find older versions of Mac OS and Xcode and other programs developed by Apple on the Apple Developer Website.

A big thanks to Pvag for his help. I wasn’t able to find 10.13.4, so I used 10.13.6. Below is the working configuration on my system. I hope it helps someone else.

MacBook Pro Retina 15-inch, Early 2013, 10,1
NVIDIA GeForce GT 650M 1024 MB

macOS 10.13.6. (17G6030)

Xcode 9.4 (9F1027a)

Cuda Driver 418.163

GPU Driver (Web Driver) 387.10.10.10.40.127

Cuda Toolkit 10.0.130

Glad it helped!

Thanks for the tips!

My rig:
MacBook Pro late 2013
Nvidia GT 750m
High Sierra 10.13.6 (17G11023)

What I did that worked:
System Preferences>Energy Saver> TURN OFF “Automatic graphics switching”
Installed latest CUDA drivers from Nvidia: https://www.nvidia.com/en-us/drivers/cuda/mac-driver-archive/
Installed latest Nvidia web drivers from here: https://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-jan-29-2020/

Blender Cycles can now use my GPU via CUDA! Woo! Hope this helps someone.