Cuda installation succeeds, but no programs can find Cuda devices

Cuda used to work on my machine, for some reason it stopped so I am trying to re-install drivers.

I’ve downloaded CUDA 5.5 for windows 64bit, and installed. I got the warning about “not-all functions available for Visual Studio Express”, but apart from that all worked fine.

However all programs (eg TechPowerUp GPU-Z) say I don’t have Cuda installed.

I’ve tried this roughly 20 times now, in different configurations. Also tried 5.0 installation. Exactly the same result.

Any ideas? Please help.

If your machine is a laptop, you might need to explicitly set the program to run on the NVIDIA card via the NVIDIA Control Panel.

it’s not a laptop.
Update: this problem periodically fixes itself, and Cuda works.
I’m seeing this same problem on BOTH of my pcs.

I’ve found the problem.
I use Remote Desktop to communicate between my PCs. Apparently this takes over the graphics driver on the host machine and disables CUDA. Use something like VNC instead.