CUDA is not enabled on OpenCV while using Leopard-Carrier Board

Hi all,

In our current project we are using Jetson-TX2 with a specialized carrier board from Leopard-Imaging (specifically the board is: LI-TX1-CB-6CAM). The main reason to chose the carrier board from Leopard is that we are also using their cameras for our project.

Our problem is that OpenCV is not able to access CUDA-Support. I tried several tutorials to install OpenCV but I always have the same result: CUDA-Support has not been activated during the installation process. To make everything clear, we flashed Linux-for-Tegra 28.1 as a standalone OS (i.e. we did not install JetPack), since this is required to make the camera drivers working without any problems. We installed CUDA v9.2 and OpenCV 3.3. Finally, and to make the picture clear, we are able to use the cameras and process the image data as we want using OpenCV, our problem is that OpenCV is not able to access CUDA.

Have anyone of you encountered such kind of problem before? What was the solution?

Thanks in advance for your help.

Hi,

I have the same exact problem.

When I flash the latest jetpack to Leopard Imaging Carrier Board first, OpenCV is installed with CUDA support but it’s not possible to use the Leopard Imaging cameras because camera driver installations can only be done by flashing Leopard Imaging’s drivers to the board again, which discards Jetpack and CUDA.

When I flash the camera installation drivers from Leopard Imaging first and then install CUDA alone from NVIDIA’s website (https://developer.nvidia.com/cuda-90-download-archive?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1604&target_type=runfilelocal) , it’s not possible to enable CUDA in the installation of OpenCV eventhough I tried many different ways. I can see that CUDA is installed from terminal but I can’t find a way to make it enabled in OpenCV installation.

In cmake configuration, I should see the following result but I couldn’t find a way to make it ‘YES’:
https://www.dropbox.com/s/eyq3ldkdhg0xas8/CUDA.jpg?dl=0

Has anyone experienced the same/similar situation before ? I’d appreciate any help :)

You have to use

-DWITH_CUDA=ON

in cmake launch before compiling opencv with cuda support (on jetson).

See https://docs.opencv.org/3.4/d6/d15/tutorial_building_tegra_cuda.html by example.

Hi,

Thanks for your response, but I already set this flag and other necessary flags to make it enabled. Problem should be something else. I also followed what people suggested on the following link, but still didn’t work:

https://stackoverflow.com/questions/46584000/cmake-error-variables-are-set-to-notfound

I already set this to be “ON” during the installation of OpenCV, but still in the showed result of cmake configuration the support of CUDA is shown as “NO”. Again I would like to mention that I’m not using JetPack, rather I have flashed Linux-for-Tegra 28.1 as standalone OS as instructed by the company Leopard-Imaging, since this is needed to install their camera drivers properly.