Cuda Libraries are missing in Windows 11 and Cuda 12.2 Toolkit

I’m trying to run Hohya_SS and keep running into the problem that /usr/local/lib64 is not found. The particular error seems to be with libcudart.so and the existence of that file. I searched my whole drive and the libraries as well as libcudart.so do not exist. I have uninstalled and reinstalled the 12.2 toolkit. I don’t know how else to install the libraries. I have set the path correctly in the Environmental Variables.

================================================================================
CUDA_SETUP: WARNING! libcudart.so not found in any environmental path. Searching in backup paths…
The following directories listed in your path were found to be non-existent: {WindowsPath(‘/usr/local/cuda/lib64’)}
DEBUG: Possible options found for libcudart.so: set()
CUDA SETUP: PyTorch settings found: CUDA_VERSION=118, Highest Compute Capability: 8.9.
CUDA SETUP: To manually override the PyTorch CUDA version please see:https://github.com/TimDettmers/bitsandbytes/blob/main/how_to_use_nonpytorch_cuda.md
CUDA SETUP: Loading binary C:\Kohya_SS-Master\venv\lib\site-packages\bitsandbytes\libbitsandbytes_cuda118.so…
argument of type ‘WindowsPath’ is not iterable
CUDA SETUP: Problem: The main issue seems to be that the main CUDA runtime library was not detected.
CUDA SETUP: Solution 1: To solve the issue the libcudart.so location needs to be added to the LD_LIBRARY_PATH variable
CUDA SETUP: Solution 1a): Find the cuda runtime library via: find / -name libcudart.so 2>/dev/null
CUDA SETUP: Solution 1b): Once the library is found add it to the LD_LIBRARY_PATH: export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:FOUND_PATH_FROM_1a
CUDA SETUP: Solution 1c): For a permanent solution add the export from 1b into your .bashrc file, located at ~/.bashrc
CUDA SETUP: Solution 2: If no library was found in step 1a) you need to install CUDA.
CUDA SETUP: Solution 2a): Download CUDA install script: wget https://github.com/TimDettmers/bitsandbytes/blob/main/cuda_install.sh
CUDA SETUP: Solution 2b): Install desired CUDA version to desired location. The syntax is bash cuda_install.sh CUDA_VERSION PATH_TO_INSTALL_INTO.
CUDA SETUP: Solution 2b): For example, “bash cuda_install.sh 113 ~/local/” will download CUDA 11.3 and install into the folder ~/local

I know nothing about pytorch, but there are a couple things at odds in the above:

and

My understanding is that the highest version of Cuda toolkit that is supported by pytorch, is 11.8, so I think that is what you need to install.

I’ve downgraded to the Cuda11.8 toolkit, and no needed libraries were installed. I still get the same error that libcudart.so it does not exist with the latest version installation.

CUDA SETUP: PyTorch settings found: CUDA_VERSION=118 which is 11.8. I wasn’t aware that Pytorch and Toolkit 12.2 needed to be the exact version number. I just thought you needed to have the latest version of each.

If you have any other thoughts let me know. Thanks, mate

If you go to the pytorch homepage, you can see there, there’s a choice between 11.7 or 11.8 builds.