CUDA libs cannot be accessed- Windows 8.1

I have a 980 and Windows 8.1 cannot access my CUDA libs. This is a sytem wide isse and localized to any single App. I have tried DDU clean uninstall and then reinstalling new drivers but that has not worked, what other steps can I take to solve this? Cuda-Z confirms my CUDA libs cannot be accessed. Thanks!

Installing GPU drivers only does not install CUDA.

You may need to install CUDA correctly. The instructions are contained in the CUDA windows install guide:

https://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html

get your installers from:

http://www.nvidia.com.com/getcuda

Really? I though the Nvidia Driver installer would place the correct drivers for using CUDA-enabled apps. Thank you for this!

It does. Depending on how the app is built. I said “you may need to” I don’t know exactly which “CUDA libs” you are referring to. There are several, some installed by the driver, some installed by the CUDA toolkit installer.

It’s also possible that if you installed drivers from other than a NVIDIA source, you didn’t get everything.

This all started when I was installing new Drivers through the GeForce Experience app and my system crashed. I suspect something went amiss. Originally I thought it localized to Redshift, a CUDA-powered Render Engine I use, but CUDA-Z has revealed the problem is systemic.

yes, that sounds like a driver issue

Ok thank you. Are there any other procedures, other than loading the CUDA toolkit you would recommend? I used DDU to do a clean uninstall of my old drivers and did a fresh install of an updated driver (Standard driver only, no additional CUDA toolkit), yet that did not fix the problem.

I have never done a separate CUDA install on this system yet I have been able to access CUDA with no issues, before now.

I have never encountered this sort of issue before so any workflow procedures you could recommend for troubleshooting would be much appreciated. Thank you again.