CUDA/NVCC cannot be found. pytorch.cuda.not available

Hello there. I have a Jetson Xavier which I flashed with JetPack 5.0.1 using NVIDIA SDK Manager. I am trying to run some GitHub projetcs related to YoloV4 and YOLOv5. However, in every single repository that I run, CUDA cannot be found by the program.

For instances, trying to run YOLOv5 with the GPU, installing the requirements that they listed in their github page, I get this:

When trying to run this repository GitHub - jkjung-avt/tensorrt_demos: TensorRT MODNet, YOLOv4, YOLOv3, SSD, MTCNN, and GoogLeNet , I get that NVCC cannot be found. However, NVCC is installed in the system. Furthermore, I already added CUDA to the bash file:

Does anyone knows why this is happening?

I would really appreciate the help! Thank you

Hi @danir1512, you should install one of the PyTorch wheels from here that was built with CUDA enabled (or use the l4t-pytorch container):

Regarding the nvcc issue, does it find nvcc if you run make without sudo? I’m curious if the path doesn’t include /usr/local/cuda/bin under the sudo environment.

Hi, i tried installing PyTorch using the link you provide an nows it seems to be detecting the GPU. However, now it says that the torchvision version is not compatible with my Pytorch version. These are my current versions:

About nvcc, if I run without sudo its the same: it is not found.

Thanks for the help!

Did you rebuild torchvision according to the directions of that PyTorch thread after you re-installed PyTorch? You may also want to try using the l4t-pytorch container which comes with these pre-installed.

I’m not sure why this particular project isn’t finding nvcc when it’s in your path - you may want to dig into it’s makefile to see how it’s found, or posting an issue on the GitHub page for this third-party project.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.