Cuda on Slackware 13 amd64

Just thought I would report on my attempts to install CUDA on Slackware 13 amd64. Wasn’t sure how to do this initially, as it didn’t appear in the supported list of Linux distros. But I thought I would give it a try, and see what would happen. The amd64 CUDA driver seems to be the same for all distros, and installed just as the normal Nvidia driver does. No problems. I just ensured no X display was running, and on the command line, as root ran

sh cudadriver_2.3_linux_64_190.18.run

This installs the driver, compiles a new kernel module, and installs opengl32 compatibility libs, if required.

Then I installed the CUDA toolkit

again as root, I ran

sh cudatoolkit_2.3_linux_64_ubuntu9.04.run

I inspected the contents of this file before running it in vim, and then got a file listing with ./cudatoolkit_2.3_linux_64_ubuntu9.04.run --list

Nothing seemed too Ubuntu specific (I didn’t read too closely though), so I ran i to see if it worked. It did!

Then I installed the SDK, by running, as a normal user,

sh cudasdk_2.3_linux.run

which installed the SDK into my home directory.

I added the /usr/local/cuda/lib64 into /etc/ld.so.conf, and added /usr/local/cuda/bin to my PATH variable in ~/.bashrc.

cd 'd into ~/NVIDIA_GPU_Computing_SDK/C and ran make to compile the example programs. All went well with nothing failing on anything. I then ran ~/NVIDIA_GPU_Computing_SDK/C/bin/linux/release/devicequery, which confirmed that it had all installed properly and was working, and detected my 9800GT. :yes:

So if anyone is looking to run CUDA on Slackware, go for it. As is typical with Slackware, it just works. This is in stark contrast to the problems I had setting CUDA up in Ubuntu Jaunty.

I haven’t had as much luck with Slackware 13-64 (Patrick’s new version). I haven’t found that any of the toolkits including the cudatoolkit_2.3_linux_64_ubuntu9.04 installs the builtin_types.h header in /usr/local/cuda/include. I have the cudadriver_2.3_linux_64_190.18 installed and it’s working fine. Any ideas?

Thank you dmdrummond, I came across this one thro’ the post on 0fnords notes on Slackware-13.0.

I managed to install the toolkit and SDK for CUDA v2.3 on my Pentium III running Slackware-13.0. I installed both as user in $HOME/… No issues there. I skipped the driver since I don’t have a CUDA-capable device on my old system. I intend to use the emulator until I can build/buy a newer system. The example build finished a short while ago. Here’re some notes:

  1. Set the environment variables as specified in the Getting Started guide after you install the toolkit and before you install the SDK to use the new installation of the toolkit (compiler, etc.), otherwise the SDK install will fail or use an older version of the toolkit if you had one and didn’t cleanup prior to the upgrade.

  2. Since I didn’t install in the default directories, I had to tweak the CUDA_INSTALL_PATH used in $NVIDIA_GPU_Computing_SDK/C/common/common.mk. The assignment for CUDA_INSTALL_PATH in common.mk evaluates to /usr/local/cuda. I forced make to use a different path instead w/ ‘make emu=1 verbose=1 CUDA_INSTALL_PATH=’. Without this nvcc wasn’t able to find builtin_types.h while making the examples, it was looking for it in /usr/local/cuda.

wjsunderland: Did you install the toolkit in the default directory (/usr/local/cuda) or someplace else? If not the default directory then #2 above maybe of interest to you.

All the non-glx test programs in …/NVIDIA_GPU_Computing_SDK/C/bin/linux/emurelease passed. They took about 5 hours to complete on my system. I don’t seem to have xorg.conf configured correctly for glx or the card is not glx-capable.

rvp@hostname:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 8
model name : Pentium III (Coppermine)
stepping : 6
cpu MHz : 863.754
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat p
se36 mmx fxsr sse up
bogomips : 1727.50
clflush size : 32
power management:

rvp@hostname:~ uname -a Linux hostname 2.6.29.6-smp #2 SMP Mon Aug 17 00:52:54 CDT 2009 i686 Pentium III (Coppermine) GenuineIntel GNU/Linux rvp@hostname:~ cat /etc/slackware-version
Slackware 13.0.0.0.0
rvp@hostname:~$