Cuda on Ubuntu 8.04 No Cuda on 8800GTS

I am running Ubuntu 8.04 and have an Nvidia 8800GTS. I have just downloaded the latest BOINC and wish to utilize the Cuda function in this video card. I have another computer with a Gforce 280 video card and am using Ubuntu on it also and when I downloaded the BOINC it found the Cuda and immediately started using it as a co-processor. According to the Nvidia website the 8800GTS also has Cuda built-in and it should be functional. When I start the same version of BOINC that I use on the other computer, the BOINC program states that it looked for Cuda but none was found. What am I going to have to do to ‘turn on’ the Cuda functions in this video card?

Thank you.

An answer to this, apparently, is to upgrade to 8.10. I tried everything else and nothing worked. After upgrading, Cuda worked.

Were you using a driver from the Ubuntu repository? You shouldn’t do that. I bet the 8.04 repo was too old to support BOINC correctly while 8.10 works (but it’s still probably not a very recent driver).

Yes. I was using the Nvidia drivers from the Ubuntu repository. I still am but they work now. I don’t know that I am getting the maximum processing from the ones I have now but they seem to be doing well from what I can see.

The info I get from glxinfo in 8.10 with drivers installed from the repo is

$ glxinfo |grep NVIDIA

server glx vendor string: NVIDIA Corporation

client glx vendor string: NVIDIA Corporation

OpenGL vendor string: NVIDIA Corporation

OpenGL version string: 2.1.2 NVIDIA 177.80

OpenGL shading language version string: 1.20 NVIDIA via Cg compiler

By the way, I dont remember how to add to the PATH the place /usr/local/cuda/bin/.

Also when I’m doing make on simpleGL ld dont find -lcutil.

----------- edit

-lcutil isnt found, because I need to do first a make on the root SDK directory for generate that lib.