cuda on ubuntu gutsy

Hi,

I just pulled the whole cuda package. I have an uptodate ubuntu running here, so I pulled the ubuntu version. But the corresponding libs seem not to work. The samples can’t resolve any symbols from them and nm tells me there really are none defined (referring to the libs in /usr/local/cuda/lib).

???

Daniel

ps: I tried both 32 and 64 bit version

Specifically which command(s) are you trying to run, and what is the output from the command(s)?

Also, which version of Ubuntu are you running?

I have success to install CUDA 1.0 on Ubuntu 7.10 but not Cuda 1.1. Need to install new beta driver. I do not know how to install new driver and will wait until beta become stable or Envy implements method for beta driver instalation.

EDIT, note to everyone else. Dont be a moron and type in nvidia instead of nv in the restricted-modules-common. I’m leaving the question in case someone else is as stupid as myself

I have a problem now that I have to reinstall the nvidia driver (169.04) everytime I reboot my machine. Otherwise it uses the xorg.conf.failsafe.

When running lsmod when X runs in failsafe mode, I get the following output:
nvidia 6221648 0
agpgart 35016 2 nvidia, intel_agp

but right after installing the nvidia driver again, I get:
lsmod | grep nvidia
nvidia 7867904 32
i2c core 26112 1 nvidia
agpgart 35016 1 nvidia, intel_agp

Any ideas?

I might be horribly wrong about this but i was having a devil of a time getting the new 169 driver runing on 64bit Gutsy. Turns out I had installed the restricted driver previously (which is i think still version 100.4 or something which certainly doesn’t work with cuda).

So i would get the beta driver working immediately after install and then the older driver would bump the new one out of the kernel when i rebooted.

I solved this by removing all of the apt packages related to restricted kernel modules and sources.

If that doesn’t help, you can try blacklisting the wrong nvidia driver in /etc/modules and /etc/modprob.d/blacklist-whatever.

If you check the xorg log (/var/log/X11 i think) you might see the error that “kernel module is wrong version” or what have you.

Hope that helps

I seem to have a problem with running desktop effects together with CUDA apps. For instance when running oceanFFT I get weird errors like:

cufft: ERROR: /root/cuda-stuff/sw/gpgpu_rel1.1/cufft/src/config.cu, line 106
cufft: ERROR: CUFFT_INTERNAL_ERROR

And frequent segmentation faults with other apps. However when I turn off desktop effects, it works very well.

What could be causing this? Could it be that I only have 128MB of memory on my GPU?

alexao,
Its quite possible that the limited framebuffer on your GPU is impacting the results, as compositing requires alot more framebuffer. I’d guess that there isn’t sufficient ‘memory’ for the CUDA work.

This could explain random machine crashes when running those applications as well

Which packages are those? I have the same problem.

EDIT:

I figured it out:

diff packages.txt “packages after restricted removal.txt”

954c954

< nvidia-glx-new install


nvidia-glx-new deinstall

If you are still struggling, check out this guide for setting up CUDA in Ubuntu Gutsy. I’m curious if it would work on 64 bit machines… Hope it helps!

Works fine on 64-bit gutsy for me.