Cuda packages for Debian 12?

We have recently purchased several A100 GPUs and an Epyc-based server to run them in. My first choice of OS, mainly due to its superior support for ZFS but also because it doesn’t use snap packages (for LXD, most importantly here), is the Debian 12 based Proxmox 8.

I have been successful in installing the Debian 11 cuda repo packages under Proxmox 8 but unfortunately its cuda drivers are too old to support the A100.

I have tried installing cuda using the Ubuntu 22.04 cuda repo under proxmox 8 but I get the error:

The following packages have unmet dependencies:
 cuda-drivers-535 : Depends: nvidia-settings (>= 535.86.10) but it is not installable
E: Unable to correct problems, you have held broken packages.

I prefer to use repos to install third party software but I’ve also tried using the runfile to install cuda and that doesn’t work either:

root@thor:/home/sgs548# sh ./ 
 Installation failed. See log at /var/log/cuda-installer.log for details.
root@thor:/home/sgs548# cat /var/log/cuda-installer.log
[INFO]: Driver not installed.
[INFO]: Checking compiler version...
[INFO]: gcc location: /usr/bin/gcc

[INFO]: gcc version: gcc version 12.2.0 (Debian 12.2.0-14) 

[INFO]: Initializing menu
[INFO]: nvidia-fs.setKOVersion(2.17.3)
[INFO]: Setup complete
[INFO]: Installing: Driver
[INFO]: Installing: 535.86.10
[INFO]: Executing --ui=none --no-questions --accept-license --disable-nouveau --no-cc-version-check --install-libglvnd  2>&1
[INFO]: Finished with code: 256
[ERROR]: Install of driver component failed. Consult the driver log at /var/log/nvidia-installer.log for more details.
[ERROR]: Install of 535.86.10 failed, quitting

When can we expect cuda packages for Debian 12?

Has anyone been successful in getting the A100 running under Debian Bookworm or proxmox 8? If so, how?


The currently supported linux distributions are always listed in the latest CUDA linux install guide.

Debian 12 is not in that list.

I’m not able to give forward-looking information.

The driver might be installable using the runfile installer. It’s not possible to deduce what went wrong since you have not given the log information that is suggested in your post:

I did provide the error output by the latest cuda Linux runfile in my previous post. See the output of cat /var/log/cuda-installer.log.


Please read my message carefully or your original post carefully. Here is what I excerpted from your post:

Here is what you provided:

Do you see the difference?

1 Like

Ah yes!

I have now got cuda running with my A100’s under proxmox 8. I had failed to install the kernel headers and dkms previously.

Before you run the cuda runfile, you must install:

apt install build-essential pve-headers dkms

To fulfill the cuda build requirements under Proxmox.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.