CUDA processor count (1) does not match graphics processor count (2)

Hi folks, the last time I tried to work on Isaac SIM was some months ago, but I quit because I had a similar problem and I said to myself that I would just wait until an update solves the issue.
Probably an update solved the past issue where the GPU was not recognized at all and the program used to immediately close by itself after starting it.
Nowadays, the program doesn’t close by itself anymore, but the viewport is bugged and says “RTX Loading” forever.
I am using a laptop ASUS ROG Flow X16, it has an integrated GPU within the CPU (AMD R9 6000s) and a dedicated GPU NVIDIA RTX3070ti 8 GB.
This laptop has a MUX Switch, I don’t know… maybe this could be the cause since is a very recent technology. I don’t have an external display for testing. I tried also Ubuntu and I have the same issue.
By default, it utilizes
CWINDOWSsystem32cmd.exe.txt (54.2 KB)

the AMD GPU to run the program, but since is very weak and without RTX maybe this is why is bugged because it could recognize the existence of an NVIDIA RTX GPU, but it uses the AMD. I have no clue, just supposing.

Hi @marian.v.danci - I am moving this question to right category and someone from our team will review and get back to you.

1 Like

Hi I have the same error:
2023-05-04 05:50:09 [716ms] [Error] [realm:gpu] could not open Success
2023-05-04 05:50:09 [799ms] [Error] [] CUDA processor count (0) does not match graphics processor count (1)

In my case Im running it on Ubuntu 22.04 with a RTX 4070ti and a Ryzen 5 5600X.

On /usr/lib/x86_64-linux-gnu i have 2 files

I don’t know if I can change the file required or i have to create the required file. I need help

1 Like

Hi, thank you! Sorry for the confusion, I didn’t know where to open this topic

Hello , i have the same problem when using the audio2face, ia have a laptop with AMD Ryzen 7 6800H with Radeon Graphics 3.20 GHz with RTX3070

2023-05-16 21:58:22 [Error] [] CUDA processor count (1) does not match graphics processor count (2)

coulyou help me find the solution please

thanks you

For whatever reason this wasn’t an issue at one point, but these days, at least for me, if you have a non Nvidia card (or embedded graphics) as a second GPU, you have to select just the NVIDIA one with some special command line sauce. Appears to be too difficult for Omniverse to select just the card(s) that will actually work with Omniverse on it’s own - which makes sense, because for all it knows, maybe you are really intent on using the card without cuda that won’t work and you might feel really foolish when things do work, but secretly your AMD embedded CPU graphics are not actually being used. That would be tragic. So this opaque fail conveniently keeps you from suffering that.

What’s that special command line sauce? I don’t remember. Audio2Face just updated and I don’t have it around anymore, so here I am looking for it again myself. Some developer whispers it somewhere in one of these forums.

Same problem. Is there any way to solve it?
Runing on Ubuntu 20.04, rtx 4090, Core i9-12900k

@rthaker hi, is there any news about it?

I solved this problem by disabling the integrated gpu. Go to Device Manager → Display adaptors. Then right click on the first (if it is not the rtx one). Then re-installed Code or Isaac inside your omniverse. Restart

For a laptop is a very bad idea, since will drastically decrease the overall performance.
I don’t want to disable it, I want that someone from NVIDIA take some action since this problem persisted for an entire year.

1 Like

the same phenomenon as you given,but on Ubuntu 20.04, rtx3080ti, Core i9-12900k.and when I run nvidia-settings,it displaye

nvidia-settings:GLib-GObject-CRITICAL **:g_object:unref:assertion ‘G_IS_OBJECT (object)’ failed.

any resoved ways?

Hey all,

I’ve just bought a £3000 laptop specifically to run omniverse in the field and I’m having this issue. Its a ROG-Zephyrus-Duo. I got this with the dual screen to run docs and across different windows when running isaac sim

Specs are

RTX 3080Ti
4AMD Radeon Graphics
AMD Ryzen 9 6900HX
Physical Memory (RAM) 64.0 GB
4tb of SSD storage
Win 11
Ubuntu to be installed for Linux RTX lidar simulation

Its an awesome laptop for productivity. I do not want to return this… its the coolest laptop ive ever had and the specs are banging! this the kind of layout you can get with it very very cool…

I have this exact same issue. I followed the advice above by @ peyman.sabouri and disabled the display adapter but this disconnects the lower screen entirely… :(

Issac sim did run proving that the CUDA processor count (1) does not match graphics processor count (2) was the issue

Look this really needs to get fixed, This is a product marketed for NVidia RTX and wont run omniverse? That’s pretty poor and i see this issue has been going on for a year from the OP

All we need is some code brother @mati-nvidia it only needs to discount the other display adapter and do the rtx as its primary or default on the RTX hardware.

It runs RTX enabled games with the second screen working so it seems specific to cuda/omniverse.

I’d would imagine that the CUDA processor count would be an integer value which throws the graphics processor count error because the values don’t match.

I take it the issue here is that Nvidia dont know which order your adapters are set up ie which place in line but surely we could do some code that lets you select it? Or you do some wizard stuff on your side… but there are thousands of RTX laptops being sold with dual screens and they currently dont work with omniverse :/

on a better note loved siggraph 2023 it was amazing, very excited about where the future is going with this,

@mati-nvidia @WendyGram

Hi @Sirens_uk. Sorry for missing the tag on this.

  1. Can anyone please verify if this is still an issue with USD Composer 2023.1.1? I’m told that this was fixed for Kit 105.

  2. In any case, Isaac Sim users won’t have access to Kit 105 for now. It looks like a possible workaround is to:

    1. Try setting mutliGpu to false by adding -–/renderer/multiGpu/enabled=false via commandline or in the app’s batch file.
    2. If that doesn’t work, you should ALSO add this flag to specify the GPU you want: -–/renderer/activeGpu=1. If that doesn’t work, try 0 or 2 depending on your setup.

Please try that out and let me know how it goes. Message me if you want to screenshare and walk through it together.

Thanks Mati let me look at it today. There is something else I want to try.

I’ll have a play today and see if I get anywhere

omni.code .txt (107 Bytes)
替换原来的code文件内的bat 文件