CUDA separate compilation and debugging

Hello,

I am experiencing serious debugging “setbacks”

Before getting to my own project, I can build the cuda C++ integration sample, but can hardly debug it (for the sake of testing my own project’s debugging) - I am greeted by the “no source available” note in the source editor

Now, as for my own project, I have multiple source files (my project is rather big) with separate compilation enabled
It compiles fine, regardless
When debugging, and when my source files are .cpp files, I run into “no source available” in the source editor (I can step in disassembly view)
When I save the same source files as .cu files, I can see and step my code in the source editor
Whenever I step my code (as .cu files) and it needs to jump (make calls) to code in another source file (same source folder, not even different source folder), it is back to “no source available”, until the call returns
When I copy the code to the initial source file so that no secondary source file is referenced during such calls, I can see and step the applicable code without problems

-g -G -O0 flags are set; have tried specifying source location under debugging configuration

What am I missing? At this point it seems that, if I want to debug my code, I would have to put everything in 1 source file…

Linux - fedora 20 3.13.6-200.fc20.x86_64
cuda5.5
Geforce Gt600 (driving screen)
Geforece Gtx 780ti

Hi,

Sorry you’re having an issue here. Unfortunately, CUDA 5.5 does not have support for Fedora 20 (CUDA 5.5 supported Fedora 18). A potential workaround is to add the “-Xcompiler -gdwarf-2” compiler flag when building your application, in order to prevent the newer host compiler from generating newer debugging information (dwarf 4).

Please consider downloading the CUDA 6.0 release candidate (https://developer.nvidia.com/cuda-pre-production), which supports Fedora 19 but generally improves cuda-gdb’s support for debugging information generated by newer compilers (such as gcc 4.8).