CUDA setup not recognizing Titan V even after driver install?

  1. I installed the latest Titan V driver as of January 3, 2018, and then re-installed Cuda toolkit 9.1 to get the message

“This graphics driver could not find compatible graphics hardware. You may continue installation, but you may not be ablle to run CUDA applications with this driver…”

  1. cannot compile anything in command prompt using nvcc

  2. can’t build any CUDA samples in visual studio (tried modifying host_config.h file, and setting visual studio to 2015 version)

  3. tensorflow scripts take between 1-10 minutes to set up the GPU before they start running…

what is going on? Is CUDA just ot connected to the titan V?

Installing the latest Titan V driver is sufficient. At that point, when you install the CUDA toolkit, you can skip the driver install. When a CUDA toolkit is bundled, the bundled driver does not necessarily recognize newer GPUs (GPUs released after the CUDA toolkit installer was created/bundled), so the message is expected in that case, which you’ll discover if you look around this forum.

Regarding VS usage, if you’re using VS2017, it requires specific steps to get it working. Take a look here for example:

https://devtalk.nvidia.com/default/topic/1027299/cuda-setup-and-installation/cuda-9-failed-to-support-the-latest-visual-studio-2017-version-15-5/4

It’s generally a lot easier to use VS 2015, because things just work in that case.

Dear txbob,

I was also stuck by TitanV.
I tried using CUDA 9.1 and Cudnn 7.0.5 on Ubuntu 16.04 LTS.
But when I using the same net and model to do segmentation for a set of images, I find that TitanV costs more time than 1080Ti.

I’m wondering whether it is because that I did not install the right version of CUDA and Cudnn ?(ps. ther driver is 390.12)