Cuda software not working over VNC connection

Hello, I am reposting this here, after having posted it on stackexchange…

I am working on some software that I created in QT Creator. It is basically running some filters on images and displaying the filtered image.

When I run this program sitting at the terminal, or over SSH, it works perfectly. However, when I run this over a VNC session, the filtered images come back looking like random noise.

It appears that the data coming back from the libraries I have linked in to my QT program area incorrect - so this explains the scrambled images. It seems like I have to figure out what could be causing those libraries (which I have source to) to give bad results only when running VNC. The image processing library is using CUDA to do the 2D convolution.

On that box, I am logged into a TTY session, which I ran “startx” on, and then killed to get back to a prompt (this loads X libs that cuda needs), and then I ran vncserver -geometry 1600x1000, and I am remoted into this box over SSH, and have a VNC client going as well.

Should I try some other configuration? I have some other CUDA stuff going on in this program that seems to be running fine - however, this one set of functions is the only ones giving me problems when running over VNC.