Cuda stopped working on Mac Mini/9400

I can no longer compile working Cuda programs on my Mac Mini (10.6.2, 9400 GPU). Until recently, I could compile and run, but anything I compile today fails to find any device supporting Cuda. I had made no changes that I am aware of.

I have tried NVidias examples though their makefiles, and my own code compiled from the command-line. Same result, no device. But the code I compiled in december works! I have reinstalled everything but nothing changed.

Reinstalling. Varying the parameters. Looking through the advice here looking for mismatches. Nothing.

The deviceQuery demo, like everything else, reports “no device supporting CUDA”.

What can be broken? Can some system update have messed up the Cuda SDK?

I think I have fixed it, with yet another complete reinstallation and a turn through the fixes. So far so good. Now it sees the 9400 again.

But I feel uneasy about it breaking in the first place. It seems to me as if the Cuda system is remarkably brittle. I still don’t know why it gave up on me. Is it “normal” that Cuda dies on e.g. system updates?