Cuda template debugging gone wrong Error 1 error C3861: '__cudaInitArgBlock': identifier not

so I am runninc cuda on Windows 7 64 bit
I downloaded and installed Cuda toolkit 3.1+SDK
followed all the instructions in the programming guide
Driver NVS 3100M on Lenovo thinkPad

AND still :mad:
I tried to run the template project and I fot the following error
Error 1 error C3861: ‘__cudaInitArgBlock’: identifier not found C:\Users\crd\AppData\Local\Temp\tmpxft_00000da8_00000000-6_template.compute_10.cudafe1.stub.c

do u have any ideas about fixing this?

I am having the same issue. I know this was awhile ago, but has anyone found a solution to this problem? The error I get is:

Error 639 error C3861: ‘__cudaSetupArgSimple’: identifier not found ProjectDirectory\spec_hier.compute_10.cudafe1.stub.c 10

I have been successfully compiling this cuda file with another set of cuda build rules, so I know the code is fine. I am currently using SDK 4.0 with VS 2008 and attempting to get NSight running so I can debug an integration issue. Please help! Thanks.

Has anyone solved this issue yet? I’m having the exact same problem C3861: ‘__cudaSetupArgSimple’: identifier not found. This started after I installed Nsight 2.0. Thanks