Cuda Toolkit 10.1 Update 2 Sample-Simulations-nBody shows Required OpenGL extensions missing

I am running the following system in Google Cloud Platform
Windows 2019 Server
16 CPU with 60GB RAM
Nvidia Tesla T4
CUDA Toolkit 10.1 Update 2
Visual Studio 2015 Update 3

I have installed the NVIDIA graphics driver. NVIDIA-SMI also shows “Driver Version: 426.00”

But, when I ran CUDA Toolkit Sample->Simulations->nBody , it shows the following screen :-
"Run “nbody -benchmark [-numbodies=]” to measure performance.
-fullscreen (run n-body simulation in fullscreen mode)
-fp64 (use double precision floating point values for simulation)
-hostmem (stores simulation data in host memory)
-benchmark (run benchmark to measure performance)
-numbodies= (number of bodies (>= 1) to run in simulation)
-device= (where d=0,1,2… for the CUDA device to use)
-numdevices= (where i=(number of CUDA devices > 0) to use for simulation)
-compare (compares simulation results running once on the default GPU and once on the CPU)
-cpu (run n-body simulation on the CPU)
-tipsy=<file.bin> (load a tipsy model file for simulation)

NOTE: The CUDA Samples are not meant for performance measurements. Results may vary when GPU Boost is enabled.

Windowed mode
Simulation data stored in video memory
Single precision floating point simulation
1 Devices used for simulation
Required OpenGL extensions missing."

May I ask what other extensions am I supposed to install for the CUDA Toolkit ? I followed the instructions from https://medium.com/@nicerova/cuda-on-windows-the-definitive-guide-b4130b9fc419

Thank you

The Tesla T4 on windows in a baremetal environment is only in TCC driver mode.

TCC driver mode does not support OpenGL (or DirectX) graphics (on windows).

Thank you Robert for your advice. I have incorporated NVIDIA GRID option in the Google Cloud Platform instance for the Tesla T4.

It is now working.

I have same issue. I am connected to my VM remotely and have following configuration.

Windows 2019 Server
Tesla V100-SXM2-16GB
Visual Studio 2019
CUDA 10.1

When i run simplegl example it shows me error
Error: Support for necessary OpenGL extensions missing.

How do i install OpenGL so that simplegl example run properly.

I switched to NVIDIA GRID (G3) and it is working fine. As i read G3 support OpenGL.