CUDA Toolkit 4.0.13 deleted /usr/bin on installation

thanks a lot for crashing my system

Any chance you could provide some additional information, like which Linux distribution you are using?

This sounds like a perfect illustration of why you shouldn’t give the toolkit installer an installation path of / .

I thought so too, but the toolkit script (at least the Ubuntu 10.10 version) appends /cuda to whatever path you type at the interactive prompt, so there is no way to install to / or /usr directly (and nuke /bin or /usr/bin). I just tried it out in a virtual machine and could not damage my files.

Is it possible to override that with a command line option?

The same for me. Also my /usr/bin/ was deleted by
and no, I did not choose a stupid install directory. Actually I was just keeping to hit enter…
I’m on a Ubuntu 11.04 64bit system. I guess the problem is that I had already some “cuda toolkit packages” installed. The install script asked whether it should delete these first. Sadly I answered yes. The install script removed directory `/usr/bin/…/bin/’ from my drive. Thanks!!

At first I had followed this howto
However, then I ran into the “API mismatch” problem (different kernel and driver). I decided to start over and follow now this howto. There I had to reinstall the cuda toolkit. Now my system is gone.

Please fix this asap because it is a very bad example of software in the form as it is now (it doesn’t help people - instead it kills time).


The CUDA installer from NVIDIA does append /cuda to all install paths so in the usual install/uninstall scenarios no one will hit this bug. Some of the use cases where this issue got repro’d finally are scenarios where user specifically moved the compiler binary nvcc to /usr/bin or the user used a 3rd party posted debian package for CUDA toolkit. In case of such usage scenarios please use the attached perl script (cuda-cleaner) which will delete only CUDA files from your custom install location where nvcc and other CUDA binaries reside.

This issue is fixed in CUDA toolkits after CUDA 4.1. (1.01 KB)

4.1.28 also erased my /usr/bin directory. I’m not pleased. Ubuntu 12.04