CUDA Toolkit 5.0 NSight build errors on Mac OS X ML

I have strange thing happened to my CUDA Toolkit 5.0.
Few days ago both XCode and NSight Eclipse plugin lost ability to build even simplest CUDA related projects. XCode successfully building projects with custom build rule for C++ source files:


But console output shows that run failed

error: executable doesn't exist: '/Users/geraldus/Library/Developer/Xcode/DerivedData/CUDA_Hello_World-gzfzqivvsmeamfghnovopxapkdsz/Build/Products/Debug/CUDA Hello World'
        error: failed to launch '/Users/geraldus/Library/Developer/Xcode/DerivedData/CUDA_Hello_World-gzfzqivvsmeamfghnovopxapkdsz/Build/Products/Debug/CUDA Hello World' -- SBTarget is invaliderror: failed to launch '/Users/geraldus/Library/Developer/Xcode/DerivedData/CUDA_Hello_World-gzfzqivvsmeamfghnovopxapkdsz/Build/Products/Debug/CUDA Hello World' -- SBTarget is invalid

And Eclipse NSight output always shows that .o file is missing.

**** Build of configuration Release for project Simple CUDA RT ****
        make all 
        Building file: ../src/Simple CUDA
        Invoking: NVCC Compiler
        nvcc -O3 -gencode arch=compute_20,code=sm_20 -gencode arch=compute_35,code=sm_35 -odir "src" -M -o "src/Simple CUDA RT.d" "../src/Simple CUDA"
        nvcc -O3   "src/Simple CUDA RT.o" "../src/Simple CUDA"
        i686-apple-darwin11-llvm-g++-4.2: src/Simple CUDA RT.o: No such file or directory
        make: *** [src/Simple CUDA RT.o] Error 1
        **** Build Finished ****

I’ve tried to rebuild CUDA samples this way:

cd /Developer/NVIDIA/CUDA-5.0/samples
        make clean

Everything was built without errors, binaries were successfully generated and they works. But still the same situation with XCode and Eclipse (even after reinstalling Eclipse and CUDA Toolkit)

How can I fix it? Is it a bug or my incorrect actions?

Can you try removing spaces from the file name?

Glad to see you here too, eugeneo!
Yes, removing whitespaces resolving the issue! Thank you a lot!
Looks like this is nvcc bug and only for OSXes.
Still need to configure somehow XCode. Looks like my custom build rule should be more complex.