CUDA Toolkit 5.5 & Fedora 19: Failed Install from Repo & gcc 4.8.1 not supported

Hi,

I just tried to install the CUDA Toolkit for Fedora 18 on FC 19. It seems like others are successful installing from the repository (and using the runfile), however, for me, both does not work.

yum install cuda results in several transaction check errors

Transaction check error:
  file /usr/share/man/man1/nvidia-xconfig.1.gz from install of nvidia-xconfig-319.37-27.fc18.x86_64 conflicts with file from package xorg-x11-drv-nvidia-1:325.15-1.fc19.x86_64
  file /usr/bin/nvidia-settings from install of nvidia-settings-319.37-30.fc18.x86_64 conflicts with file from package xorg-x11-drv-nvidia-1:325.15-1.fc19.x86_64
  file /usr/share/applications/nvidia-settings.desktop from install of nvidia-settings-319.37-30.fc18.x86_64 conflicts with file from package xorg-x11-drv-nvidia-1:325.15-1.fc19.x86_64
  file /usr/share/man/man1/nvidia-settings.1.gz from install of nvidia-settings-319.37-30.fc18.x86_64 conflicts with file from package xorg-x11-drv-nvidia-1:325.15-1.fc19.x86_64

and trying to install via the runfile (not selecting the driver for install) complains about

Unsupported compiler: 4.8.1

I use rpmfusion drivers + kmod. The thread about deviceQuerys failing on fedora 19 shows that it technically should work installing the toolkit using gcc 4.8.1.

Is there a way to resolve the conflicts/the problem with gcc?

Thanks & Regards

edit: Ok, installing the toolkit worked by first extracting the contents of the runfile and installing toolkit & samples separately. However, I am now facing the problem, that running Samples results in “cudaErrorInsufficientDriver”. My driver version should be working though (325.15) - any reason why it shouldn’t?

edit2: Alright, the solution presented in https://devtalk.nvidia.com/default/topic/615263/cuda-5-5-or-5-0-fails-devicequery-on-fedora19/?offset=4 did it for me. Problem solved!

./cuda_5.5.22.linux_64.run -override compiler