Cuda toolkit 7.5 does not support current Ubuntu 14.04.5

Ubuntu HWE stack in 14.04.4 came to EOL 4th of Aug so it required to be updated so that kernel remains updateable (see https://wiki.ubuntu.com/1404_HWE_EOL).

I did the HWE stack update as suggested by Ubuntu SW Updater and tried then to install current Nvidia Cuda Toolkit 7.5. It fails with:
$ sudo apt-get install cuda

Some packages could not be installed.

The following packages have unmet dependencies:
cuda : Depends: cuda-7-5 (= 7.5-18) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

In another identical Ubuntu machine that had Cuda toolkit installed and working, new HWE stack install fails with similar dependency problems.

Question: when will the Cuda toolkit support Ubuntu 14.04 current HWE stack (Kernel v4.4)?

Try switching to CUDA 8RC. Or wait until CUDA 8 comes out.

You could also try using the runfile installer method rather than the package manager method for installation.

It’s unlikely that CUDA 7.5 would ever be updated.