Cuda toolkit 7.5 for OpenSuSE Leap 42.1


Does anyone know when will the Cuda toolkit 7.5 for OpenSuSE Leap 42.1 (64bit) be available for download?

I installed the latest NVIDIA driver for OpenSuSE Leap 42.1, and tried the Cuda toolkit 7.5 for OpenSuSE 13.2, the toolkit required an older version of NVIDIA driver, and caused an unstable graphic desktop environment.


I was able to install CUDA 7.5 in openSUSE 42.1, but when compiled this code:

#include <stdio.h>

__global__ void cube(float * d_out, float * d_in){
	// Todo: Fill in this function

int main(int argc, char ** argv) {
	const int ARRAY_SIZE = 64;
	const int ARRAY_BYTES = ARRAY_SIZE * sizeof(float);

	// generate the input array on the host
	float h_in[ARRAY_SIZE];
	for (int i = 0; i < ARRAY_SIZE; i++) {
		h_in[i] = float(i);
	float h_out[ARRAY_SIZE];

	// declare GPU memory pointers
	float * d_in;
	float * d_out;

	// allocate GPU memory
	cudaMalloc((void**) &d_in, ARRAY_BYTES);
	cudaMalloc((void**) &d_out, ARRAY_BYTES);

	// transfer the array to the GPU
	cudaMemcpy(d_in, h_in, ARRAY_BYTES, cudaMemcpyHostToDevice);

	// launch the kernel
	cube<<<1, ARRAY_SIZE>>>(d_out, d_in);

	// copy back the result array to the CPU
	cudaMemcpy(h_out, d_out, ARRAY_BYTES, cudaMemcpyDeviceToHost);

	// print out the resulting array
	for (int i =0; i < ARRAY_SIZE; i++) {
		printf("%f", h_out[i]);
		printf(((i % 4) != 3) ? "\t" : "\n");


	return 0;

Received completely wrong output.
Is CUDA functioning right on openSUSE 42.1?

Some hours ago I made a test on LinuxMint 17.3.
Same error with the same code.

This code is from Udacity - Intro to Parallel Programming
So I think its got to be correct.

The code apparently expects you to fill in the code for the kernel:

__global__ void cube(float * d_out, float * d_in){
	// Todo: Fill in this function

without you adding some code in the “Todo” section, I don’t see how you could expect that kernel to do anything.

The d_out and h_out variables will contain junk, unless you actually put some code in that kernel.

This is so embarrassing…
I didn’t even looked to it.

Thank you. Will fill it down.

All works perfectly.

One more time thanks.