cuda toolkit 9.0 and 9.1 fail with no clear error why. Logs attached


I run the cuda installer and get error saying all not-installed. I ran also extracted the files and ran:

setup.exe -log:"F:\NVIDIA_CUDA" -loglevel:6

This did not seem to make a difference. Logs attached.

The only real error I see before the installer goes into failed mode is this one:

DEBUG: [DisplayDriver.DisplayDriverExtSite] 1698@CDisplayDriverExtSite::MapINFFlagsToProperties : Found NVAllowMCVirtualAudioPreStage with value of 0. 
     24.474 |     INFO: [DisplayDriver.DisplayDriverExtSite] 3149@CDisplayDriverExtSite::ProcessDowngradeBehavior : Clean install on downgrade is not required in the extension. 
     24.474 |     INFO: [DisplayDriver.DisplayDriverExtSite] 3049@CDisplayDriverExtSite::ProcessForceCleanBehavior : Force clean is not required in the extension. 
     24.474 |    DEBUG: [DisplayDriver.DisplayDriverExtSite] 4083@CDisplayDriverExtSite::PerformOptimusRemovalAnalysis : Determining if Optimus should be removed. 
     24.474 |    DEBUG: [DisplayDriver.DisplayDriverExtSite] 4146@CDisplayDriverExtSite::PerformOptimusRemovalAnalysis : Optimus should remain, no further actions. 
     24.489 |    ERROR: [NVI2.InstallThread] 54@CInstallThread::ThreadProc : Install failed - Exception {0x80070002 - The system cannot find the file specified.; File: InstallationStepper.cpp; Line: 769; Extension failed during call toAnalyze} - going to fail state. 
     24.490 |    DEBUG: [NVI2.Installation] 107@CInstallationStepper::Present : Presenting "!InstallFailed". 
     24.490 |     INFO: [NVI2UI.MainFrame] 2589@CMainFrame::FlushEvents : Property changed "NextFormGroup".

Please let me know what steps I can try.

LOG.setup.exe.log (298 KB)

9.0 and 9.1 logs look very similar.