CUDA Toolkit Installer Hangs Upgrading from 2.0 Beta to 2.0 Final

I’m upgrading my system to the CUDA 2.0 Final software today; I’ve installed the newest drivers, the 2.0 SDK, and now I’m trying to install the 2.0 Toolkit. However, when the installer goes to remove the old toolkit, it just sits there and hangs, saying “NVIDIA CUDA Toolkit is configuring your new software installation.”

Any ideas? I’ve tried removing the old install via Add/Remove Programs, but it does the same thing (I presume they both launch the same un-installer).

If it matters, I’m on XP Professional 64-bit.

I have the same problem with the 2.0 beta2 installers for both the toolkit and the SDK.

I’m on XP SP3 (32bit).

No event log messages or clues…

… same thing happens if you just run the 2.0 final installer, and it tries to uninstall the beta version.

Anyone know how I can get final installed?

EDIT2: Reboot fixed it.

On shutdown it complained that the DDE Server had hung…

Annoyingly it still happens with 2.2 final…

the same problem with the 2.2 toolkit installer on XP SP3 (32bit)

I deleted all the files related to cuda in the register. But the problem still exits.

Anyone know how to fix this.

Thanks.

Unfortuantely I have the same problem. I can neither install nor uninstall CUDA Toolkit.

Note that I have CUDA 2.3 SDK already installed in my system.

Here’s the error I get when I try to uninstall:

Anyone who solved this issue yet?

Best Regards,
Aram
when_Unistalling_NVidia_CUDA_Toolkit2.jpg
when_Unistalling_NVidia_CUDA_Toolkit.jpg